summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorulaktar2018-07-29 21:44:26 +0100
committerulaktar2018-07-29 22:05:15 +0100
commit472b8a8f125cebe66ebf0ecbc5325182d837daec (patch)
tree2154e985369a847234e3c81a39da5ea7e95be98f
downloadaur-brother-mfc-9465cdn.tar.gz
Added LPR and CUPS driver for the Brother MFC-9465CDN
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
-rw-r--r--brother-mfc-9465cdn.install12
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d0134475206
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = brother-mfc-9465cdn
+ pkgdesc = LPR and CUPS driver for the Brother MFC-9465CDN
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
+ install = brother-mfc-9465cdn.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = tcsh
+ depends = deb2targz
+ depends = perl
+ depends = a2ps
+ depends = lib32-glibc
+ source = http://www.brother.com/pub/bsc/linux/dlf/mfc9465cdnlpr-1.1.1-5.i386.deb
+ source = http://www.brother.com/pub/bsc/linux/dlf/mfc9465cdncupswrapper-1.1.1-5.i386.deb
+ md5sums = d5bfd57216e53cfaf7c04de42055209e
+ md5sums = 31480002670c88352c3525a37d678bea
+
+pkgname = brother-mfc-9465cdn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea5137e49a47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Taras Ulakhovich <taras.ulakhovich@gmail.com>
+# Based on brother-mfc-9460cdn package from AUR
+
+_model="9465cdn"
+pkgname="brother-mfc-$_model"
+pkgver="1.1.1"
+pkgrel=1
+pkgdesc="LPR and CUPS driver for the Brother MFC-9465CDN"
+arch=('i686' 'x86_64')
+url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
+license=('unknown')
+depends=('tcsh' 'deb2targz' 'perl' 'a2ps')
+if test "$CARCH" == x86_64; then
+ depends+=(lib32-glibc)
+fi
+install="brother-mfc-${_model}.install"
+_revision=5
+
+source=("http://www.brother.com/pub/bsc/linux/dlf/mfc${_model}lpr-${pkgver}-${_revision}.i386.deb"
+ "http://www.brother.com/pub/bsc/linux/dlf/mfc${_model}cupswrapper-${pkgver}-${_revision}.i386.deb")
+md5sums=('d5bfd57216e53cfaf7c04de42055209e'
+ '31480002670c88352c3525a37d678bea')
+
+
+build() {
+ deb2targz *.deb >/dev/null || return 1
+ rm -f *.deb || return 1
+ cd $srcdir || return 1
+ [ -d "mfc${_model}" ] || (mkdir mfc${_model} || return 1)
+ for i in *.tar.gz;do tar xfz $i -C mfc${_model};done || return 1
+ cd mfc${_model} || return 1
+ cd usr/local/Brother/Printer/mfc${_model} || return 1
+ perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrappermfc${_model} || return 1
+ perl -i -pe 's#printcap\.local#printcap#g' $srcdir/mfc${_model}/usr/local/Brother/Printer/mfc${_model}/inf/setupPrintcapij || return 1
+}
+
+package() {
+ cp -rf $srcdir/mfc${_model}/usr/ $pkgdir/ || return 1
+}
diff --git a/brother-mfc-9465cdn.install b/brother-mfc-9465cdn.install
new file mode 100644
index 000000000000..7c18158aec66
--- /dev/null
+++ b/brother-mfc-9465cdn.install
@@ -0,0 +1,12 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ /usr/local/Brother/Printer/mfc9465cdn/cupswrapper/cupswrappermfc9465cdn >/dev/null
+ if [ "$?" -eq 0 ]; then
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. The printer should be visible now via the CUPS-webinterface (http://localhost:631)\n"
+ else
+ printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
+ fi
+}