summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranz Rogar2016-11-11 17:33:59 +0100
committerFranz Rogar2016-11-11 17:33:59 +0100
commit9e025c7a0e075655da9c31d4d4ea024b0ada0f7b (patch)
treefea31b86c1c54cc6e69873637a534ece37f30723
downloadaur-9e025c7a0e075655da9c31d4d4ea024b0ada0f7b.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
-rw-r--r--brother-mfc-j220.install9
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83eaab0c4dc8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = brother-mfc-j220
+ pkgdesc = LPR and CUPS driver for the Brother MFC-J220
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/
+ install = brother-mfc-j220.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother commercial license
+ depends = cups
+ depends = perl
+ depends = bash
+ depends = lib32-glibc
+ source = http://www.brother.com/pub/bsc/linux/dlf/mfcj220lpr-1.1.3-1.i386.rpm
+ source = http://www.brother.com/pub/bsc/linux/dlf/mfcj220cupswrapper-1.1.3-1.i386.rpm
+ md5sums = 931b168c320049ae20a1b5939f5da31e
+ md5sums = 37bbde153ca2e3ac5005f637ce5a4fbb
+
+pkgname = brother-mfc-j220
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d845f2b4093
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Franz Rogar <franzrogar@gmail.com>
+# Modified AUR [brother-mfc-j220] package by Franz Rogar <franzrogar@gmail.com>
+# Original AUR [brother-hll2300d] package maintained by Mykola Bespaliuk (kolkabes [at] gmail [dot] com)
+pkgname="brother-mfc-j220"
+_model="j220"
+pkgver="1.1.3"
+pkgrel=1
+pkgdesc="LPR and CUPS driver for the Brother MFC-J220"
+url="http://solutions.brother.com/linux/en_us/"
+license=('custom:brother commercial license')
+
+arch=('i686' 'x86_64')
+
+depends=('cups' 'perl' 'bash')
+if test "$CARCH" == x86_64; then
+ depends+=('lib32-glibc')
+fi
+
+install="$pkgname.install"
+
+source=("http://www.brother.com/pub/bsc/linux/dlf/mfcj220lpr-$pkgver-$pkgrel.i386.rpm"
+ "http://www.brother.com/pub/bsc/linux/dlf/mfcj220cupswrapper-$pkgver-$pkgrel.i386.rpm"
+)
+md5sums=('931b168c320049ae20a1b5939f5da31e'
+ '37bbde153ca2e3ac5005f637ce5a4fbb'
+)
+
+prepare() {
+echo "unpacking"
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ install -m 0755 -o root -g root "${srcdir}/usr/bin/brprintconf_mfcj220" "${pkgdir}/usr/bin/brprintconf_mfcj220"
+
+ mkdir -p "${pkgdir}/opt"
+ cp -R "${srcdir}/opt/brother" "${pkgdir}/opt/brother"
+
+ mkdir -p "${pkgdir}/usr/lib/cups/filter"
+ echo "#! /opt/brother/Printers/mfcj220/lpd/filtermfcj220" > "${srcdir}/filter-shim"
+ install -m 0755 -o root -g root "${srcdir}/filter-shim" "${pkgdir}/usr/lib/cups/filter/filtermfcj220"
+
+ mkdir -p "${pkgdir}/usr/share/ppd/cupsfilters"
+ install -m 0644 -o root -g root "${srcdir}/opt/brother/Printers/mfcj220/cupswrapper/brother_mfcj220_printer_en.ppd" "${pkgdir}/usr/share/ppd/cupsfilters"
+}
diff --git a/brother-mfc-j220.install b/brother-mfc-j220.install
new file mode 100644
index 000000000000..3ddb04120f84
--- /dev/null
+++ b/brother-mfc-j220.install
@@ -0,0 +1,9 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+echo "Restart CUPS to load the new files"
+echo "You can now register your new printer using the web interface at:"
+echo " http://localhost:631/"
+}