summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Schäferdiek2015-06-15 00:17:02 +0200
committerAlexander Schäferdiek2015-06-15 00:17:02 +0200
commita70bccc02b1d9fc18648c5e282091cb7fd84ff50 (patch)
tree78413a373f47898c41ea340f545cc7cbfb540c9d
downloadaur-a70bccc02b1d9fc18648c5e282091cb7fd84ff50.tar.gz
Initial import
-rwxr-xr-x.SRCINFO13
-rwxr-xr-xPKGBUILD19
-rwxr-xr-xbrother-mfc-j430w.install12
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..d43a5b152f58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = brother-mfc-j430w
+ pkgdesc = LPR and CUPS driver for the Brother MFC-J430W
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
+ install = brother-mfc-j430w.install
+ arch = any
+ license = unknown
+ source = https://www.schaeferdiek.eu/downloads/Linux/AUR/brother-mfc-j430w-3.0.1-1.tar.gz
+ md5sums = adcf866f27c2fa13f81286874f7f8204
+
+pkgname = brother-mfc-j430w
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..38e92866ead4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Varakh <varakh[at]varakh[dot]de>
+pkgname=brother-mfc-j430w
+pkgver=3.0.1
+pkgrel=1
+pkgdesc="LPR and CUPS driver for the Brother MFC-J430W"
+url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
+license=('unknown')
+install='brother-mfc-j430w.install'
+arch=('any')
+source=("https://www.schaeferdiek.eu/downloads/Linux/AUR/${pkgname}-${pkgver}-${pkgrel}.tar.gz")
+md5sums=('adcf866f27c2fa13f81286874f7f8204')
+
+# server doesn't like the curl header
+DLAGENTS="$( IFS=$'\n'; echo "${DLAGENTS[*]}" | grep '^http::' ) --user-agent 'Mozilla/4.0'"
+
+package() {
+ cp -rf $srcdir/usr/ $pkgdir || return 1
+ cp -rf $srcdir/opt/ $pkgdir || return 1
+}
diff --git a/brother-mfc-j430w.install b/brother-mfc-j430w.install
new file mode 100755
index 000000000000..b1e732e8d5aa
--- /dev/null
+++ b/brother-mfc-j430w.install
@@ -0,0 +1,12 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ /opt/brother/Printers/mfcj430w/cupswrapper/cupswrappermfcj430w >/dev/null
+ if [ "$?" -eq 0 ]; then
+ printf "Printer enabled. If it is a network printer, change ip address in CUP interface (localhost:631).\n"
+ else
+ printf "Could not enable the printer in the CUP service.\n"
+ fi
+}