summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristina Vitting2019-10-31 22:06:51 -0400
committerChristina Vitting2019-10-31 22:06:51 -0400
commitc2db8d6ba36e1a84e6e02b91f216712f69a01aec (patch)
treefd7424ada28c89b3cd357991b997218d29e04ea8
downloadaur-c2db8d6ba36e1a84e6e02b91f216712f69a01aec.tar.gz
Added package to AUR
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD49
-rw-r--r--brother-mfc-j497dw.install12
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d06339f81df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = brother-mfc-j497dw
+ pkgdesc = LPR and CUPS driver for the Brother MFC-J497DW
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/
+ install = brother-mfc-j497dw.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother commercial license
+ depends = cups
+ depends = ghostscript
+ depends = gsfonts
+ optdepends = brscan4
+ optdepends = brscan-skey
+ source = http://www.brother.com/pub/bsc/linux/packages/mfcj497dwpdrv-1.0.5-0.i386.rpm
+ md5sums = 5a3f823f2c7cb6d1718c2277fa949b40
+ depends_x86_64 = lib32-glibc
+
+pkgname = brother-mfc-j497dw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5c078f3b12d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Christina Vitting <(firstname)(lastname) @ gmail.com>
+
+pkgname="brother-mfc-j497dw"
+pkgver="1.0.5"
+pkgrel=1
+pkgdesc="LPR and CUPS driver for the Brother MFC-J497DW"
+arch=('i686' 'x86_64')
+url="http://solutions.brother.com/linux/en_us/"
+license=('custom:brother commercial license')
+depends=('cups'
+ 'ghostscript'
+ 'gsfonts')
+depends_x86_64=('lib32-glibc')
+optdepends=('brscan4' 'brscan-skey')
+install="$pkgname.install"
+source=("http://www.brother.com/pub/bsc/linux/packages/mfcj497dwpdrv-1.0.5-0.i386.rpm")
+md5sums=('5a3f823f2c7cb6d1718c2277fa949b40')
+
+prepare() {
+ # setup cups-directories
+ install -d $srcdir/usr/share/cups/model
+ install -d $srcdir/usr/lib/cups/filter
+
+ # go to the cupswrapper directory and find the source file from which to generate a ppd- and wrapper-file
+ cd `find . -type d -name 'cupswrapper'`
+ if [ -f cupswrapper* ]; then
+ _wrapper_source=`ls cupswrapper*`
+ sed -i '/^\/etc\/init.d\/cups/d' $_wrapper_source
+ sed -i '/^sleep/d' $_wrapper_source
+ sed -i '/^lpadmin/d' $_wrapper_source
+ sed -i 's|/usr|$srcdir/usr|g' $_wrapper_source
+ sed -i 's|/opt|$srcdir/opt|g' $_wrapper_source
+ sed -i 's|/model/Brother|/model|g' $_wrapper_source
+ sed -i 's|lpinfo|echo|g' $_wrapper_source
+ export srcdir=$srcdir
+ ./$_wrapper_source
+ sed -i 's|$srcdir||' $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ sed -i "s|$srcdir||" $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ rm $_wrapper_source
+ fi
+
+ # /etc/printcap is managed by cups
+ rm `find $srcdir -type f -name 'setupPrintcap*'`
+}
+
+package() {
+ cp -R $srcdir/usr $pkgdir
+ if [ -d $srcdir/opt ]; then cp -R $srcdir/opt $pkgdir; fi
+}
diff --git a/brother-mfc-j497dw.install b/brother-mfc-j497dw.install
new file mode 100644
index 000000000000..0d4a23db3be8
--- /dev/null
+++ b/brother-mfc-j497dw.install
@@ -0,0 +1,12 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ echo "Restart CUPS to load the new files"
+ echo "You can now register your new printer using the web interface at:"
+ echo " http://localhost:631/"
+ echo "To print over wireless, choose the 'LPD/LPR Host or Printer' protocol"
+ echo "when adding the printer, and use the following connection:"
+ echo " lpd://ipaddress/queue"
+}