summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Abel2017-09-02 17:12:18 +0200
committerBenjamin Abel2017-09-02 17:18:10 +0200
commit94b4f05849184dff915a52729490a315c9b2a578 (patch)
treeb82918230d8d4a6595650a569b89edef6854b48c
parentf237e98cb917e9e47fd50e9ceaab5f2229b78d05 (diff)
downloadaur-94b4f05849184dff915a52729490a315c9b2a578.tar.gz
Add a patch in cupswrapper
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
-rw-r--r--brother-mfc-j5335dw.patch12
3 files changed, 25 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9382cf13de61..89067d7a3d59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = brother-mfc-j5335dw
pkgdesc = LPR and CUPS driver for the Brother MFC-J5335DW
- pkgver = 1.0.1.0
+ pkgver = 1.0.1.0.1
pkgrel = 3
url = http://support.brother.com/g/b/downloadtop.aspx?c=fr&lang=fr&prod=mfcj5335dw_eu
install = brother-mfc-j5335dw.install
@@ -16,10 +16,13 @@ pkgbase = brother-mfc-j5335dw
source = http://download.brother.com/welcome/dlf103028/mfcj5335dwcupswrapper-1.0.1-0.i386.rpm
source = cupswrapper-license.txt
source = lpr-license.txt
+ source = brother-mfc-j5335dw.patch
md5sums = bcf37fe0e9624ae9e3ce0554573d113f
md5sums = 40c5de6899b0c319f6187e23626e7c42
md5sums = 310f8424517f3df127d39393ceaebb6f
- md5sums = bf894a1a51baf6055a6c58ecf43c9782
+ md5sums = bf894a1a51baf6055a6c58ecf43c9782,
+ md5sums = 4bd2a2f6fb33b2fcf4c6d22810238dc7
depends_x86_64 = lib32-glibc
pkgname = brother-mfc-j5335dw
+
diff --git a/PKGBUILD b/PKGBUILD
index a909353570de..57d9a150a613 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# slightly modified version of https://aur.archlinux.org/packages/brother-mfc-j5330dw/
pkgname="brother-mfc-j5335dw"
-pkgver="1.0.1.0"
+pkgver="1.0.1.0.1"
# required because of unconventional package numbering for brother
_brother_pkgver="1.0.1-0"
pkgrel=3
@@ -17,11 +17,13 @@ install="$pkgname.install"
source=("http://download.brother.com/welcome/dlf103004/mfcj5335dwlpr-$_brother_pkgver.i386.rpm"
"http://download.brother.com/welcome/dlf103028/mfcj5335dwcupswrapper-$_brother_pkgver.i386.rpm"
'cupswrapper-license.txt'
- 'lpr-license.txt')
+ 'lpr-license.txt'
+ 'brother-mfc-j5335dw.patch')
md5sums=(bcf37fe0e9624ae9e3ce0554573d113f
40c5de6899b0c319f6187e23626e7c42
310f8424517f3df127d39393ceaebb6f
- bf894a1a51baf6055a6c58ecf43c9782)
+ bf894a1a51baf6055a6c58ecf43c9782,
+ 4bd2a2f6fb33b2fcf4c6d22810238dc7)
prepare() {
# do not install in /usr/local
@@ -36,6 +38,9 @@ prepare() {
install -d "${srcdir}"/usr/share/cups/model
install -d "${srcdir}"/usr/lib/cups/filter
+ # patch an error (?) in the perl script from brother
+ patch -p1 "${srcdir}"/opt/brother/Printers/mfcj5335dw/cupswrapper/brother_lpdwrapper_mfcj5335dw < brother_lpdwrapper_mfcj5335dw.patch
+
# go to the cupswrapper directory and find the source file from which to generate a ppd and wrapperfile
cd `find . -type d -name 'cupswrapper'`
diff --git a/brother-mfc-j5335dw.patch b/brother-mfc-j5335dw.patch
new file mode 100644
index 000000000000..4b862d4037fc
--- /dev/null
+++ b/brother-mfc-j5335dw.patch
@@ -0,0 +1,12 @@
+--- pkg/brother-mfcj5335dw/opt/brother/Printers/mfcj5335dw/cupswrapper/brother_lpdwrapper_mfcj5335dw 2016-08-17 07:39:28.000000000 +0200
++++ brother-mfc-j5335dw.patch 2017-09-02 16:59:33.243622717 +0200
+@@ -89,6 +89,9 @@
+ $PRINTER =~ s/\/cupswrapper//g;
+ $PRINTER =~ s/\///g;
+
++my $PRINTER = "mfcj5335dw";
++my $basedir = "/opt/brother/Printers/mfcj5335dw";
++
+ for (my $i = 0 ; $i < @ARGV ; $i ++){
+ logprint( 0 , "ARG$i = $ARGV[$i]\n");
+ }