summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDino Morelli2015-07-02 10:28:07 -0400
committerDino Morelli2015-07-02 10:28:07 -0400
commit96439825cb5cedf37cac77e85879fd915a734269 (patch)
treefce2ea03c55e13bcbe2216dd575cb888d5c84eae
parent2796f8bea78298c8a21dc785faf4032e8b8e110d (diff)
downloadaur-96439825cb5cedf37cac77e85879fd915a734269.tar.gz
Fixed problem with lpr version
Package was not building correct lpr driver version. Fixed with changes from p1rox <p1rox@p1rox.fr>. Thanks! Also fixed incorrect license field (it wasn't a list). Also separated build and package tasks.
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ae1232eaa41..6d5f40c6fb63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,25 @@
_model="j625dw"
pkgname="brother-mfc-$_model"
-pkgver="3.0.0"
-pkgrel=1
+pkgver="3.0"
+pkgrel=2
pkgdesc="LPR and CUPS driver for the Brother MFC-J625DW"
arch=('i686' 'x86_64')
url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
-license='unknown'
+license=('unknown')
depends=('tcsh' 'deb2targz' 'perl' 'a2ps')
if test "$CARCH" == x86_64; then
depends+=(lib32-glibc)
fi
install="brother-mfc-${_model}.install"
_revision=1
-source=("http://www.brother.com/pub/bsc/linux/dlf/mfc${_model}lpr-${pkgver}-${_revision}.i386.deb"
- "http://www.brother.com/pub/bsc/linux/dlf/mfc${_model}cupswrapper-${pkgver}-${_revision}.i386.deb")
+source=("http://www.brother.com/pub/bsc/linux/dlf/mfc${_model}lpr-${pkgver}.1-${_revision}.i386.deb"
+ "http://www.brother.com/pub/bsc/linux/dlf/mfc${_model}cupswrapper-${pkgver}.0-${_revision}.i386.deb")
-md5sums=('35b9436ddceb9480e750529b4a4573ff'
+md5sums=('73b9a05efb33f895e5ffe2f3c4c01fdc'
'a4a35a5ad3cfd3bb016941afff79425e')
-package() {
+build() {
deb2targz *.deb >/dev/null || return 1
rm -f *.deb || return 1
cd $srcdir || return 1
@@ -31,6 +31,9 @@ package() {
cd opt/brother/Printers/mfc${_model} || return 1
perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrappermfc${_model} || return 1
perl -i -pe 's#printcap\.local#printcap#g' $srcdir/mfc${_model}/opt/brother/Printers/mfc${_model}/inf/setupPrintcapij || return 1
+}
+
+package() {
cp -rf $srcdir/mfc${_model}/usr/ $pkgdir/ || return 1
cp -rf $srcdir/mfc${_model}/opt/ $pkgdir/ || return 1
}