summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-03-30 20:38:58 -0400
committerSolomon Choina2020-03-30 20:38:58 -0400
commit981b0f6893691ec3eb0762919ed5d9f9836340c0 (patch)
tree5ebf3ab8598dcb89e54a031b7298ea0ee1748588
downloadaur-981b0f6893691ec3eb0762919ed5d9f9836340c0.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e249e55b4ca0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = brother-mfc-j805dw
+ pkgdesc = CUPS driver for Brother mfc-JX05DW(XL) printer
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://support.brother.com/g/b/faqtop.aspx?c=us&lang=en&prod=mfcj805dw_us
+ arch = i686
+ arch = x86_64
+ license = EULA
+ depends = lib32-gcc-libs
+ depends = perl
+ depends = bash
+ source = https://download.brother.com/welcome/dlf104569/mfcj805dwpdrv-1.0.5-0.i386.deb
+ sha256sums = f299b9674d5edb9c16b5fdbfd39d9ed6b6618f2a30ad942181180e59d3e7a68d
+
+pkgname = brother-mfc-j805dw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c461cd03dfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+#!/usr/bin/bash
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+pkgname=brother-mfc-j805dw
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="CUPS driver for Brother mfc-JX05DW(XL) printer"
+arch=("i686" "x86_64")
+depends=('lib32-gcc-libs' 'perl' 'bash' )
+url="https://support.brother.com/g/b/faqtop.aspx?c=us&lang=en&prod=mfcj805dw_us"
+license=("EULA")
+source=("https://download.brother.com/welcome/dlf104569/mfcj805dwpdrv-1.0.5-0.i386.deb")
+sha256sums=('f299b9674d5edb9c16b5fdbfd39d9ed6b6618f2a30ad942181180e59d3e7a68d')
+
+package() {
+ tar -xf data.tar.gz -C "${pkgdir}"
+
+ install -m 755 -d $pkgdir/usr/share/ppd/Brother/
+ ln -s /opt/brother/Printers/mfcj805dw/cupswrapper/brother_mfcj805dw_printer_en.ppd $pkgdir/usr/share/ppd/Brother/
+
+ install -m 755 -d $pkgdir/usr/lib/cups/filter/
+ ln -s /opt/brother/Printers/mfcj805dw/cupswrapper/brother_lpdwrapper_mfcj805dw $pkgdir/usr/lib/cups/filter/
+
+ install -m 755 -d $pkgdir/usr/share/cups/Model/Brother/
+ ln -s /opt/brother/Printers/mfcj805d/cupswrapper/brother_mfcj805dw_printer_en.ppd $pkgdir/usr/share/cups/Model/Brother/
+}
+
+