summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Lackerbauer2015-12-02 13:30:20 +0100
committerSimon Lackerbauer2015-12-02 13:30:20 +0100
commitc7206e88aa329d140ad2ca7a97ff144cbaf084f3 (patch)
tree74bea18c5aae6311edb26a41838c99247dc2f424
parent0976d040aa03ecd3ce00bee24ae4d2b4130a7061 (diff)
downloadaur-c7206e88aa329d140ad2ca7a97ff144cbaf084f3.tar.gz
add removal of created symbolic links
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD9
-rw-r--r--brother-mfc-l2700dn.install13
3 files changed, 20 insertions, 6 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7bfbf973855e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.rpm
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 0d6192c77f90..9cd798ab4374 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Simon Lackerbauer <simon@lackerbauer.com>
pkgname="brother-mfc-l2700dn"
pkgver="3.2.0"
-pkgrel=1
-pkgdesc="LPR and CUPS driver for the Brother MFC-L2700DN"
+_brotherpkgrel=1
+pkgrel=2
+pkgdesc="LPR and CUPS driver for the Brother MFC-L2700DN printer"
arch=('i686' 'x86_64')
url="http://solutions.brother.com/linux/en_us/"
license=('custom:brother commercial license')
depends=('cups')
install="$pkgname.install"
source=(
- "http://download.brother.com/welcome/dlf102083/mfcl2700dnlpr-$pkgver-$pkgrel.i386.rpm"
- "http://download.brother.com/welcome/dlf102084/mfcl2700dncupswrapper-$pkgver-$pkgrel.i386.rpm"
+ "http://download.brother.com/welcome/dlf102083/mfcl2700dnlpr-$pkgver-$_brotherpkgrel.i386.rpm"
+ "http://download.brother.com/welcome/dlf102084/mfcl2700dncupswrapper-$pkgver-$_brotherpkgrel.i386.rpm"
'cupswrapper-license.txt'
'lpr-license.txt'
)
diff --git a/brother-mfc-l2700dn.install b/brother-mfc-l2700dn.install
index b8187cdf71f2..10cd082412a8 100644
--- a/brother-mfc-l2700dn.install
+++ b/brother-mfc-l2700dn.install
@@ -3,9 +3,18 @@ post_install() {
}
post_upgrade() {
- sudo ln -sf /opt/brother/Printers/MFCL2700DN/cupswrapper/brother_lpdwrapper_MFCL2700DN /usr/lib/cups/filter/
- sudo ln -sf /opt/brother/Printers/MFCL2700DN/cupswrapper/brother-MFCL2700DN-cups-en.ppd /usr/share/ppd/cupsfilters/
+ sudo ln -s /opt/brother/Printers/MFCL2700DN/cupswrapper/brother_lpdwrapper_MFCL2700DN /usr/lib/cups/filter/
+ sudo ln -s /opt/brother/Printers/MFCL2700DN/cupswrapper/brother-MFCL2700DN-cups-en.ppd /usr/share/ppd/cupsfilters/
echo "Restart CUPS (sudo systemctl restart org.cups.cupsd.service) to load the new files"
echo "You can now register your new printer using the web interface at:"
echo " http://localhost:631/"
}
+
+pre_upgrade() {
+ pre_remove;
+}
+
+pre_remove() {
+ sudo rm /usr/lib/cups/filter/brother_lpdwrapper_MFCL2700DN
+ sudo rm /usr/share/ppd/cupsfilters/brother-MFCL2700DN-cups-en.ppd
+}