summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzugno2020-07-05 23:05:48 +0200
committerzugno2020-07-05 23:05:48 +0200
commitfb6f51b7a0ef7f3088642f95ebbc78316e9fd381 (patch)
tree4ed8468a7433d5279f0d87b033bd173167706d14
parent42d4cce5510551f008d2fc9b714c09109b1fb9b3 (diff)
downloadaur-fb6f51b7a0ef7f3088642f95ebbc78316e9fd381.tar.gz
Added lib32-glibc x86_64 dependency and brscan4 optional dependency for scanner support
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD78
2 files changed, 48 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0382d01e79a..8bb773890c7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = brother-mfc-l2700dn
pkgdesc = LPR and CUPS driver for the Brother MFC-L2700DN printer
pkgver = 3.2.0
- pkgrel = 2
+ pkgrel = 3
url = http://solutions.brother.com/linux/en_us/
install = brother-mfc-l2700dn.install
arch = i686
arch = x86_64
license = custom:brother commercial license
depends = cups
+ optdepends = brscan4: scanner support
source = http://download.brother.com/welcome/dlf102083/mfcl2700dnlpr-3.2.0-1.i386.rpm
source = http://download.brother.com/welcome/dlf102084/mfcl2700dncupswrapper-3.2.0-1.i386.rpm
source = cupswrapper-license.txt
@@ -16,6 +17,7 @@ pkgbase = brother-mfc-l2700dn
md5sums = 207f6d06b06b91101d7619539f553bd7
md5sums = 97ad0cffd216059e9d1d3121899d8646
md5sums = 5e87a3dc0f3e3438c088eda0f3565f0d
+ depends_x86_64 = lib32-glibc
pkgname = brother-mfc-l2700dn
diff --git a/PKGBUILD b/PKGBUILD
index 9cd798ab4374..e426939e7999 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,71 @@
-# Maintainer: Simon Lackerbauer <simon@lackerbauer.com>
+# Maintainer: Simon Lackerbauer < mail [at] ciil [dot] io >
+# Co-maintainer: Christian Zugno < chriszugno [at] gmail [dot] com >
+
pkgname="brother-mfc-l2700dn"
pkgver="3.2.0"
_brotherpkgrel=1
-pkgrel=2
+pkgrel=3
pkgdesc="LPR and CUPS driver for the Brother MFC-L2700DN printer"
arch=('i686' 'x86_64')
url="http://solutions.brother.com/linux/en_us/"
license=('custom:brother commercial license')
depends=('cups')
+depends_x86_64=('lib32-glibc')
+optdepends=('brscan4: scanner support')
install="$pkgname.install"
+
source=(
"http://download.brother.com/welcome/dlf102083/mfcl2700dnlpr-$pkgver-$_brotherpkgrel.i386.rpm"
"http://download.brother.com/welcome/dlf102084/mfcl2700dncupswrapper-$pkgver-$_brotherpkgrel.i386.rpm"
'cupswrapper-license.txt'
'lpr-license.txt'
)
+
md5sums=('ca17e1de085202ae4678aeedb6d14941'
'207f6d06b06b91101d7619539f553bd7'
'97ad0cffd216059e9d1d3121899d8646'
'5e87a3dc0f3e3438c088eda0f3565f0d'
)
+
prepare() {
-# do not install in '/usr/local'
- if [ -d $srcdir/usr/local/Brother ]; then
- install -d $srcdir/usr/share
- mv $srcdir/usr/local/Brother/ $srcdir/usr/share/brother
- rm -rf $srcdir/usr/local
- sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
- fi
-# setup cups-directories
- install -d $srcdir/usr/share/cups/model
- install -d $srcdir/usr/lib/cups/filter
-# go to the cupswrapper directory and find the source file from wich to generate a ppd- and wrapper-file
- cd `find . -type d -name 'cupswrapper'`
- if [ -f cupswrapper* ]; then
- _wrapper_source=`ls cupswrapper*`
- sed -i '/^\/etc\/init.d\/cups/d' $_wrapper_source
- sed -i '/^sleep/d' $_wrapper_source
- sed -i '/^lpadmin/d' $_wrapper_source
- sed -i 's|/usr|$srcdir/usr|g' $_wrapper_source
- sed -i 's|/opt|$srcdir/opt|g' $_wrapper_source
- sed -i 's|/model/Brother|/model|g' $_wrapper_source
- sed -i 's|lpinfo|echo|g' $_wrapper_source
- export srcdir=$srcdir
- ./$_wrapper_source
- sed -i 's|$srcdir||' $srcdir/usr/lib/cups/filter/*lpdwrapper*
- sed -i "s|$srcdir||" $srcdir/usr/lib/cups/filter/*lpdwrapper*
- rm $_wrapper_source
- fi
-# /etc/printcap is managed by cups
- rm `find $srcdir -type f -name 'setupPrintcap*'`
+ # do not install in '/usr/local'
+ if [ -d $srcdir/usr/local/Brother ]; then
+ install -d $srcdir/usr/share
+ mv $srcdir/usr/local/Brother/ $srcdir/usr/share/brother
+ rm -rf $srcdir/usr/local
+ sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
+ fi
+
+ # setup cups-directories
+ install -d $srcdir/usr/share/cups/model
+ install -d $srcdir/usr/lib/cups/filter
+
+ # go to the cupswrapper directory and find the source file from wich to generate a ppd- and wrapper-file
+ cd `find . -type d -name 'cupswrapper'`
+ if [ -f cupswrapper* ]; then
+ _wrapper_source=`ls cupswrapper*`
+ sed -i '/^\/etc\/init.d\/cups/d' $_wrapper_source
+ sed -i '/^sleep/d' $_wrapper_source
+ sed -i '/^lpadmin/d' $_wrapper_source
+ sed -i 's|/usr|$srcdir/usr|g' $_wrapper_source
+ sed -i 's|/opt|$srcdir/opt|g' $_wrapper_source
+ sed -i 's|/model/Brother|/model|g' $_wrapper_source
+ sed -i 's|lpinfo|echo|g' $_wrapper_source
+ export srcdir=$srcdir
+ ./$_wrapper_source
+ sed -i 's|$srcdir||' $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ sed -i "s|$srcdir||" $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ rm $_wrapper_source
+ fi
+
+ # /etc/printcap is managed by cups
+ rm `find $srcdir -type f -name 'setupPrintcap*'`
}
+
package() {
- cp -R $srcdir/usr $pkgdir
- if [ -d $srcdir/opt ]; then cp -R $srcdir/opt $pkgdir; fi
+ cp -R $srcdir/usr $pkgdir
+ if [ -d $srcdir/opt ]; then cp -R $srcdir/opt $pkgdir; fi
+
install -m 644 -D cupswrapper-license.txt $pkgdir/usr/share/licenses/${pkgname}/cupswrapper-licence.txt
install -m 644 -D lpr-license.txt $pkgdir/usr/share/licenses/${pkgname}/lpr-licence.txt
}