summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEddie Ringle2018-07-10 10:57:58 -0500
committerEddie Ringle2018-07-10 10:57:58 -0500
commitac3487aac853085a07973e39294baa1bea7f2208 (patch)
treee294576d7b6f0b9c4140e8761a4f7c101062b37a
downloadaur-brother-mfc-l2750dw.tar.gz
Initial import
MFC-L2750DW Signed-off-by: Eddie Ringle <eddie@ringle.io>
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD45
-rw-r--r--brother-mfc-l2750dw.install10
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9972461942f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = brother-mfc-l2750dw
+ pkgdesc = LPR and CUPS driver for the Brother MFC-l2750DW
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/
+ install = brother-mfc-l2750dw.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother commercial license
+ depends = cups
+ source = http://download.brother.com/welcome/dlf103529/mfcl2750dwpdrv-4.0.0-1.i386.rpm
+ md5sums = 74e8e59060d8038bfb9090091354bf09
+ depends_x86_64 = lib32-glibc
+
+pkgname = brother-mfc-l2750dw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b736af21c82a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Eddie Ringle <eddie@ringle.io>
+# based on https://aur.archlinux.org/packages/brother-mfc-l2713dw/
+pkgname="brother-mfc-l2750dw"
+pkgver="4.0.0"
+pkgrel=1
+pkgdesc="LPR and CUPS driver for the Brother MFC-l2750DW"
+url="http://solutions.brother.com/linux/en_us/"
+arch=("i686" "x86_64")
+license=("custom:brother commercial license")
+depends=("cups")
+depends_x86_64=("lib32-glibc")
+install="$pkgname.install"
+source=(
+ "http://download.brother.com/welcome/dlf103529/mfcl2750dwpdrv-$pkgver-$pkgrel.i386.rpm"
+)
+md5sums=(
+ "74e8e59060d8038bfb9090091354bf09"
+)
+
+package() {
+ _model="MFCL2750DW"
+ # using /usr/share instead of /opt
+ mkdir -p "$pkgdir/usr/share"
+ cp -R "$srcdir/opt/brother" "$pkgdir/usr/share"
+ sed -i 's|\\\/opt\\\/|\\\/usr\\\/|' "$pkgdir/usr/share/brother/Printers/$_model/cupswrapper/lpdwrapper"
+ sed -i 's|\\\/opt\\\/|\\\/usr\\\/|' "$pkgdir/usr/share/brother/Printers/$_model/lpd/lpdfilter"
+
+ # /etc/printcap is managed by cups
+ find "$pkgdir" -type f -name 'setupPrintcap*' -delete
+
+ # symlink for lpdwrapper so it correctly figures out the printer model from the path
+ install -d "$pkgdir/usr/lib/cups/filter/"
+ ln -s "/usr/share/brother/Printers/$_model/cupswrapper/lpdwrapper" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_$_model"
+
+ # symlink for the PPD
+ install -d "$pkgdir/usr/share/cups/model/"
+ ln -s "/usr/share/brother/Printers/$_model/cupswrapper/brother-$_model-cups-en.ppd" "$pkgdir/usr/share/cups/model/"
+
+ # a couple architecture-specific symlinks
+ ln -s "/usr/share/brother/Printers/$_model/lpd/$CARCH/brprintconflsr3" "$pkgdir/usr/share/brother/Printers/$_model/lpd/"
+ ln -s "/usr/share/brother/Printers/$_model/lpd/$CARCH/rawtobr3" "$pkgdir/usr/share/brother/Printers/$_model/lpd/"
+
+ # symlink for inf because it tries to execute it there
+ ln -s "/usr/share/brother/Printers/$_model/inf" "$pkgdir/usr/share/brother/Printers/$_model/lpd/"
+}
diff --git a/brother-mfc-l2750dw.install b/brother-mfc-l2750dw.install
new file mode 100644
index 000000000000..0d1bc1b7b7a7
--- /dev/null
+++ b/brother-mfc-l2750dw.install
@@ -0,0 +1,10 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ echo "Restart CUPS (org.cups.cupsd.service) in order to load the new files."
+ echo "Register the new print at \"http://localhost:631/\"."
+ echo -e "\n To avoid errors like \"Unable to locate printer...\" when printing via network:"
+ echo " Add the printer with its socked address \"socket://<printer ip>:9100\""
+}