summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Ott2016-02-29 10:10:45 +0100
committerJens Ott2016-02-29 10:10:45 +0100
commit36a88b369103fd0f3f0f8ed31b129d5b5d44d0b0 (patch)
tree9cbe97f42d9ba7315a6bdf63001cc2bd3b10fa12
downloadaur-36a88b369103fd0f3f0f8ed31b129d5b5d44d0b0.tar.gz
Create driver-package for Brother MFC-L8650cdw
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
-rw-r--r--brother-mfc-l8650cdw.install12
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8707392c475
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Mon Feb 29 09:01:27 UTC 2016
+pkgbase = brother-mfc-l8650cdw
+ pkgdesc = LPR and CUPS driver for the Brother MFC-L8650CDW
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
+ install = brother-mfc-l8650cdw.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = tcsh
+ depends = deb2targz
+ depends = perl
+ depends = a2ps
+ depends = lib32-libcups
+ source = http://download.brother.com/welcome/dlf101088/mfcl8650cdwlpr-1.1.2-1.i386.deb
+ source = http://download.brother.com/welcome/dlf101089/mfcl8650cdwcupswrapper-1.1.2-1.i386.deb
+ sha256sums = 3c9367b144c067f1c9e51b974f8c1e23a1294aa6fd572d4aa229af15ca066e10
+ sha256sums = 2437531477231ec1c9833725e69882d82c2cfb42d7e17e535619d767733e7515
+
+pkgname = brother-mfc-l8650cdw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e57c5502585d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+model="l8650cdw"
+pkgname="brother-mfc-$model"
+pkgver="1.1.2"
+pkgrel=1
+_revision=1
+pkgdesc="LPR and CUPS driver for the Brother MFC-L8850CDW"
+url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
+arch=('i686' 'x86_64')
+license=('unknown')
+install="brother-mfc-${model}.install"
+depends=('tcsh' 'deb2targz' 'perl' 'a2ps' 'lib32-libcups')
+source=("http://download.brother.com/welcome/dlf101088/mfc${model}lpr-${pkgver}-${_revision}.i386.deb"
+ "http://download.brother.com/welcome/dlf101089/mfc${model}cupswrapper-${pkgver}-${_revision}.i386.deb")
+sha256sums=('3c9367b144c067f1c9e51b974f8c1e23a1294aa6fd572d4aa229af15ca066e10'
+ '2437531477231ec1c9833725e69882d82c2cfb42d7e17e535619d767733e7515')
+
+
+package() {
+ deb2targz *.deb >/dev/null || return 1
+ rm -f *.deb || return 1
+ cd $srcdir || return 1
+ [ -d "mfc${model}" ] || (mkdir mfc${model} || return 1)
+ for i in *.tar.gz;do tar xfz $i -C mfc${model};done || return 1
+ cd mfc${model} || return 1
+ cd opt/brother/Printers/mfc${model} || return 1
+ perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrappermfc${model} || return 1
+ perl -i -pe 's#printcap\.local#printcap#g' $srcdir/mfc${model}/opt/brother/Printers/mfc${model}/inf/setupPrintcapij || return 1
+ cp -rf $srcdir/mfc${model}/usr/ $pkgdir/ || return 1
+ cp -rf $srcdir/mfc${model}/opt/ $pkgdir/ || return 1
+}
diff --git a/brother-mfc-l8650cdw.install b/brother-mfc-l8650cdw.install
new file mode 100644
index 000000000000..b3687f6789e4
--- /dev/null
+++ b/brother-mfc-l8650cdw.install
@@ -0,0 +1,12 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ /opt/brother/Printers/mfcl8650cdw/cupswrapper/cupswrappermfcl8650cdw >/dev/null
+ if [ "$?" -eq 0 ]; then
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. The printer should be visible now via the CUPS-webinterface (http://localhost:631)\n"
+ else
+ printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
+ fi
+}