summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorloqy2021-12-21 03:39:03 -0600
committerloqy2021-12-21 03:39:03 -0600
commit605fc17afe37c811a4e6f89e264406652f0ef1b6 (patch)
tree2ba9c6ae4c8be55768fd1ffaa458d453154222ff
parent88274091347126bdfbc21f1f148b08860023fe16 (diff)
downloadaur-605fc17afe37c811a4e6f89e264406652f0ef1b6.tar.gz
update cupswrapper to 1.1.3-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
-rw-r--r--brother-mfc-l8850cdw.install17
3 files changed, 47 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 737d4d74826b..17402a4be1a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
-# Generated by mksrcinfo v8
-# Thu May 12 20:35:33 UTC 2016
pkgbase = brother-mfc-l8850cdw
pkgdesc = LPR and CUPS driver for the Brother MFC-L8850CDW
- pkgver = 1.1.2
+ pkgver = 1.1.3
pkgrel = 1
- url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
+ url = https://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
install = brother-mfc-l8850cdw.install
arch = i686
arch = x86_64
- license = unknown
- depends = tcsh
- depends = deb2targz
- depends = perl
+ license = custom:brother
depends = a2ps
+ depends = cups
depends = lib32-libcups
- source = http://download.brother.com/welcome/dlf101092/mfcl8850cdwlpr-1.1.2-1.i386.deb
- source = http://download.brother.com/welcome/dlf101093/mfcl8850cdwcupswrapper-1.1.2-1.i386.deb
+ optdepends = brscan4: scanning support
+ optdepends = brscan-skey: scanner button support
+ source = https://download.brother.com/welcome/dlf101092/mfcl8850cdwlpr-1.1.2-1.i386.deb
+ source = https://download.brother.com/welcome/dlf101093/mfcl8850cdwcupswrapper-1.1.3-1.i386.deb
sha256sums = 7e681eb44a81e018706319f2f99ef1372ff75488c83573b94cfd1bcc1522ae0c
- sha256sums = 9c8969ca59410804dbaf80e7bc437fbed5576a9c8fa68c061c2d48cc130afb04
+ sha256sums = 5c469daaf22c6d59d7290c1b3265567a512f2f67697725c85fe66aeb39d23990
pkgname = brother-mfc-l8850cdw
-
diff --git a/PKGBUILD b/PKGBUILD
index d5b39e9e380e..17d2cbbaece5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,34 @@
+# Contributor: maltzer
model="l8850cdw"
pkgname="brother-mfc-${model}"
-pkgver="1.1.2"
+pkgver="1.1.3"
pkgrel=1
_revision=1
pkgdesc="LPR and CUPS driver for the Brother MFC-L8850CDW"
-url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
+url="https://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
arch=('i686' 'x86_64')
-license=('unknown')
+license=('custom:brother')
install="brother-mfc-${model}.install"
-depends=('tcsh' 'deb2targz' 'perl' 'a2ps' 'lib32-libcups')
-source=("http://download.brother.com/welcome/dlf101092/mfc${model}lpr-${pkgver}-${_revision}.i386.deb"
- "http://download.brother.com/welcome/dlf101093/mfc${model}cupswrapper-${pkgver}-${_revision}.i386.deb")
+depends=('a2ps' 'cups' 'lib32-libcups')
+optdepends=('brscan4: scanning support' 'brscan-skey: scanner button support')
+source=("https://download.brother.com/welcome/dlf101092/mfc${model}lpr-1.1.2-1.i386.deb"
+ "https://download.brother.com/welcome/dlf101093/mfc${model}cupswrapper-1.1.3-1.i386.deb")
sha256sums=('7e681eb44a81e018706319f2f99ef1372ff75488c83573b94cfd1bcc1522ae0c'
- '9c8969ca59410804dbaf80e7bc437fbed5576a9c8fa68c061c2d48cc130afb04')
-
+ '5c469daaf22c6d59d7290c1b3265567a512f2f67697725c85fe66aeb39d23990')
package() {
- deb2targz *.deb >/dev/null || return 1
- rm -f *.deb || return 1
- cd $srcdir || return 1
- [ -d "mfc${model}" ] || (mkdir mfc${model} || return 1)
- for i in *.tar.gz;do tar xfz $i -C mfc${model};done || return 1
- cd mfc${model} || return 1
- cd opt/brother/Printers/mfc${model} || return 1
- perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrappermfc${model} || return 1
- perl -i -pe 's#printcap\.local#printcap#g' $srcdir/mfc${model}/opt/brother/Printers/mfc${model}/inf/setupPrintcapij || return 1
- cp -rf $srcdir/mfc${model}/usr/ $pkgdir/ || return 1
- cp -rf $srcdir/mfc${model}/opt/ $pkgdir/ || return 1
+ cd ${srcdir} || return 1
+ mkdir lpr cups
+ ar x mfcl8850cdwlpr-1.1.2-1.i386.deb --output=lpr >/dev/null || return 1
+ ar x mfcl8850cdwcupswrapper-1.1.3-1.i386.deb --output=cups >/dev/null || return 1
+ rm -f *.deb || return 1
+ rm -f lpr/control.tar.gz lpr/debian-binary cups/control.tar.gz cups/debian-binary || return 1
+ tar xzf lpr/data.tar.gz -C ${srcdir}
+ tar xzf cups/data.tar.gz -C ${srcdir}
+ rm -rf lpr cups
+ cd ${srcdir}/opt/brother/Printers/mfc${model} || return 1
+ sed -i 's#/etc/init\.d#/etc/rc\.d#g' ./cupswrapper/cupswrappermfc${model} || return 1
+ sed -i 's#printcap\.local#printcap#g' ./inf/setupPrintcapij || return 1
+ cp -rf ${srcdir}/usr/ ${pkgdir}/ || return 1
+ cp -rf ${srcdir}/opt/ ${pkgdir}/ || return 1
}
diff --git a/brother-mfc-l8850cdw.install b/brother-mfc-l8850cdw.install
index e14e5f5e00da..292ce5b74aaf 100644
--- a/brother-mfc-l8850cdw.install
+++ b/brother-mfc-l8850cdw.install
@@ -3,9 +3,22 @@ post_install() {
}
post_upgrade() {
- /opt/brother/Printers/mfcl8850cdw/cupswrapper/cupswrappermfcl8850cdw >/dev/null
+ /opt/brother/Printers/mfcl8850cdw/cupswrapper/cupswrappermfcl8850cdw > /dev/null
if [ "$?" -eq 0 ]; then
- printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. The printer should be visible now via the CUPS-webinterface (http://localhost:631)\n"
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. If this is a network printer, please go to http://localhost:631/printers and modify it like so:\n"
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m \"LPD/LPR Host or Printer\" or \"AppSocket/HP JetDirect\" for Device\n"
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m lpd://(Your printer's IP address)/binary_p1 for Device URI"
+ printf "Brother for Make/Manufacturer Selection"
+ printf "Your printer's name for Model/Driver Selection"
+ else
+ printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
+ fi
+}
+
+pre_remove() {
+ /opt/brother/Printers/mfcl8850cdw/cupswrapper/cupswrappermfcl8850cdw -e > /dev/null
+ if [ "$?" -eq 0 ]; then
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. Make sure your printer is removed here: http://localhost:631/printers"
else
printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
fi