summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfunilrys2023-04-21 20:58:49 +0200
committerfunilrys2023-04-21 20:58:49 +0200
commita8d3c2d904e39a4a7fae03fcdb7cadc3c8054c03 (patch)
treebd4b72186cad8f8980187f471d17348a11d3369b
downloadaur-a8d3c2d904e39a4a7fae03fcdb7cadc3c8054c03.tar.gz
Initial Commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..531582b71f6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = brother-mfct920dw
+ pkgdesc = Brother MFC-T920DW CUPS driver
+ pkgver = 3.5.0
+ pkgrel = 1
+ url = http://www.brother.com
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = custom
+ depends = cups
+ depends = ghostscript
+ source = https://download.brother.com/welcome/dlf105186/mfct920dwpdrv-3.5.0-1.i386.rpm
+ sha512sums = 762042c93536606e2fe620b7a0e0eeb54215d962915c10f5a249a55f27681db6fbdba47b0031762947172a3368482da006d5af68ee426ff0188d3930aecefe76
+ depends_x86_64 = lib32-glibc
+
+pkgname = brother-mfct920dw
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a12e163eb9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Nissar Chababy <funilrys at outlook dot com>
+
+pkgname=brother-mfct920dw
+pkgver=3.5.0
+pkgrel=1
+pkgdesc="Brother MFC-T920DW CUPS driver"
+arch=('i686' 'x86_64' 'aarch64' 'armv7h')
+url="http://www.brother.com"
+license=('custom')
+depends=('cups' 'ghostscript')
+depends_x86_64=('lib32-glibc')
+
+source=("https://download.brother.com/welcome/dlf105186/mfct920dwpdrv-${pkgver}-1.i386.rpm")
+sha512sums=('762042c93536606e2fe620b7a0e0eeb54215d962915c10f5a249a55f27681db6fbdba47b0031762947172a3368482da006d5af68ee426ff0188d3930aecefe76')
+package(){
+ install -d "${pkgdir}/usr/share/${pkgname}"
+ cp -R "$srcdir/opt/brother/Printers/mfct920dw/." "${pkgdir}/usr/share/${pkgname}/"
+
+ install -d "${pkgdir}/usr/lib/cups/filter/"
+ ln -s "/usr/share/${pkgname}/cupswrapper/brother_lpdwrapper_mfct910dw" "${pkgdir}/usr/lib/cups/filter/brother_lpdwrapper_mfct910dw"
+
+ install -d "$pkgdir/usr/share/cups/model/"
+ ln -s "/usr/share/${pkgname}/cupswrapper/brother_mfct920dw_printer_en.ppd" "${pkgdir}/usr/share/cups/model"
+
+ install -Dm644 "${pkgdir}/usr/share/${pkgname}/LICENSE_ENG.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE_ENG.txt"
+ install -Dm644 "${pkgdir}/usr/share/${pkgname}/LICENSE_JPN.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE_JPN.txt"
+}