summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgS6442015-07-25 17:51:39 +0200
committergS6442015-07-25 17:51:39 +0200
commit5f353b02c4fbaf70ec5cd429224784736ae2de7b (patch)
tree9b0c4336a6016b5208200609919de72ee09ad00a
downloadaur-5f353b02c4fbaf70ec5cd429224784736ae2de7b.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
-rw-r--r--brother-ql700-cupswrapper.install16
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca980bbdd1ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = brother-ql700-cupswrapper
+ pkgdesc = LPR-to-CUPS wrapper for Brother P-Touch QL-700 labelprinter (metric)
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/
+ install = brother-ql700-cupswrapper.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = rpmextract
+ makedepends = cpio
+ depends = cups
+ depends = ghostscript
+ depends = glibc
+ depends = brother-ql700-lpr
+ noextract = ql700cupswrapper-1.0.2-0.i386.rpm
+ source = http://download.brother.com/welcome/dlfp002193/ql700cupswrapper-1.0.2-0.i386.rpm
+ md5sums = 9315769e988fbb2088a3ec1875d2189f
+
+pkgname = brother-ql700-cupswrapper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..956ce603aaa5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Sebastian Lau <lauseb644@gmail.com>
+# Contributor: Jacob Alexander <triplehaata@gmail.com>
+# Based on the QL-500 PKGBUILD -> K. Hampf <khampf@users.sourceforge.net>
+pkgname=brother-ql700-cupswrapper
+_pkgname=ql700cupswrapper
+pkgver=1.0.2
+pkgrel=1
+_brotherrel=0
+pkgdesc="LPR-to-CUPS wrapper for Brother P-Touch QL-700 labelprinter (metric)"
+url="http://solutions.brother.com/linux/en_us/"
+arch=('i686' 'x86_64')
+license=("GPL2")
+if [ $CARCH == "x86_64" ]; then
+ depends=('cups' 'ghostscript' 'lib32-glibc' 'brother-ql700-lpr')
+else
+ depends=('cups' 'ghostscript' 'glibc' 'brother-ql700-lpr')
+fi
+makedepends=('rpmextract' 'cpio')
+source=("http://download.brother.com/welcome/dlfp002193/ql700cupswrapper-$pkgver-$_brotherrel.i386.rpm")
+md5sums=('9315769e988fbb2088a3ec1875d2189f')
+noextract=("$_pkgname-$pkgver-$_brotherrel.i386.rpm")
+install='brother-ql700-cupswrapper.install'
+
+build() {
+ cd $srcdir
+ rpmextract.sh "$_pkgname-$pkgver-$_brotherrel.i386.rpm"
+
+ rm -f $_pkgname-$pkgver-$_brotherrel.i386.rpm
+}
+
+package() {
+ mv opt $pkgdir/. || return 1
+}
diff --git a/brother-ql700-cupswrapper.install b/brother-ql700-cupswrapper.install
new file mode 100644
index 000000000000..562525212640
--- /dev/null
+++ b/brother-ql700-cupswrapper.install
@@ -0,0 +1,16 @@
+# Install file for brother-ql700-cupswrapper
+
+post_install() {
+ /opt/brother/PTouch/ql700/cupswrapper/cupswrapperql700pt1
+ systemctl restart cups
+}
+
+pre_remove() {
+ /opt/brother/PTouch/ql700/cupswrapper/cupswrapperql700pt1 -e
+}
+
+post_remove() {
+ systemctl restart cups
+}
+
+