summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDj Isaac2024-01-17 12:44:56 -0600
committerDj Isaac2024-01-17 12:44:56 -0600
commita7a693bd96bdeccb6ef0c63a3c877271802f5e8a (patch)
tree425d809a0cd9e11f2f1152490f8d44e47d01415b
parent37a27dbd6e78c4422d6c75643b61458b6737444f (diff)
downloadaur-a7a693bd96bdeccb6ef0c63a3c877271802f5e8a.tar.gz
v1.6.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b10c0587c7e9..b338644e551d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bruno-electron
pkgdesc = Bruno, an opensource API Client for Exploring and Testing APIs using the system provided Electron
- pkgver = 1.5.1
+ pkgver = 1.6.1
pkgrel = 1
url = https://www.usebruno.com/
arch = x86_64
@@ -10,9 +10,9 @@ pkgbase = bruno-electron
depends = nodejs>=18.13.0
provides = bruno
conflicts = bruno
- source = bruno-1.5.1.tar.gz::https://github.com/usebruno/bruno/archive/v1.5.1.tar.gz
+ source = bruno-1.6.1.tar.gz::https://github.com/usebruno/bruno/archive/v1.6.1.tar.gz
source = com.usebruno.app.Bruno.desktop
- sha256sums = 5118f4eaf343d8cf355cec2cc3eb15450318b88e38dc1407954e5f9baba02f80
+ sha256sums = a048cb35ce4fd4696140f40a076a8403a76dbe9b9c65b8db2db984f7e3bd2783
sha256sums = 7bad0d66e67fdaaf99d1b7b32ba2f119b7d6dba12ecfdb398c39ee3c81bbe051
pkgname = bruno-electron
diff --git a/PKGBUILD b/PKGBUILD
index c1ef751fa2f9..64e26d0b859e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=bruno-electron
_pkgname=bruno
pkgdesc="Bruno, an opensource API Client for Exploring and Testing APIs using the system provided Electron"
-pkgver=1.5.1
+pkgver=1.6.1
pkgrel=1
conflicts=('bruno')
provides=('bruno')
@@ -26,7 +26,7 @@ source=(
)
sha256sums=(
- '5118f4eaf343d8cf355cec2cc3eb15450318b88e38dc1407954e5f9baba02f80' # bruno
+ 'a048cb35ce4fd4696140f40a076a8403a76dbe9b9c65b8db2db984f7e3bd2783' # bruno
'7bad0d66e67fdaaf99d1b7b32ba2f119b7d6dba12ecfdb398c39ee3c81bbe051' # bruno.desktop
)
@@ -36,7 +36,7 @@ prepare() {
# disabling husky however I can since I'm not in a git repository
sed -i -e 's/"husky":.*//g' -e 's/"husky install"/"true"/g' package.json
- npm install --cache "${srcdir}/npm-cache"
+ npm install --legacy-peer-deps --cache "${srcdir}/npm-cache"
}
build() {
@@ -45,14 +45,14 @@ build() {
cd "${_pkgname}-${pkgver}"
- npm run build:bruno-query
npm run build:graphql-docs
+ npm run build:bruno-query
npm run build:web
electronDist="/usr/lib/${_electron}"
electronVer="$(cat ${electronDist}/version)"
- sed -i -e "s~\"dist\":.*~\"dist\": \"electron-builder --linux --x64 --dir --config electron-builder-config.js -c.electronDist=${electronDist} -c.electronVersion=${electronVer}\",~g" packages/bruno-electron/package.json
-
+ sed -i -e "s~\"dist:linux\":.*~\"dist:linux\": \"electron-builder --linux --x64 --dir --config electron-builder-config.js -c.electronDist=${electronDist} -c.electronVersion=${electronVer}\",~g" packages/bruno-electron/package.json
+
npm run build:electron:linux
}