summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDj Isaac2024-04-05 17:23:12 -0500
committerDj Isaac2024-04-05 17:23:12 -0500
commitb3c98cbbffad9988f8724710f046c7718e4e921c (patch)
tree70b251283384cea0947e00e5c995ecfe8d73b799
parent50f72cf38517720d83c41f2de2b37f01906040cc (diff)
downloadaur-b3c98cbbffad9988f8724710f046c7718e4e921c.tar.gz
bruno v1.12.3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rwxr-xr-xupdate.sh3
3 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 478f3c858e20..f6f8087d3e77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = bruno-electron
pkgdesc = Bruno, an opensource API Client for Exploring and Testing APIs using the system provided Electron
- pkgver = 1.12.1
+ pkgver = 1.12.3
pkgrel = 1
url = https://www.usebruno.com/
arch = x86_64
license = MIT
makedepends = asar
+ makedepends = npm
depends = electron>=21.0.0
depends = nodejs>=18.13.0
provides = bruno
conflicts = bruno
- source = bruno-1.12.1.tar.gz::https://github.com/usebruno/bruno/archive/v1.12.1.tar.gz
+ source = bruno-1.12.3.tar.gz::https://github.com/usebruno/bruno/archive/v1.12.3.tar.gz
source = com.usebruno.app.Bruno.desktop
- sha256sums = e4c3f2e4aa01537d4e336802acd8e979fec9bbb00fd99996216b0e9264f0087f
+ sha256sums = 4e964b5b053318d7604362aabc9b88ae2a4d58e39dadbe14e8083d7d1e38f987
sha256sums = 7bad0d66e67fdaaf99d1b7b32ba2f119b7d6dba12ecfdb398c39ee3c81bbe051
pkgname = bruno-electron
diff --git a/PKGBUILD b/PKGBUILD
index ffcaf39978a0..8e1c6a3faf9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=bruno-electron
_pkgname=bruno
pkgdesc="Bruno, an opensource API Client for Exploring and Testing APIs using the system provided Electron"
-pkgver=1.12.1
+pkgver=1.12.3
pkgrel=1
conflicts=('bruno')
provides=('bruno')
@@ -18,6 +18,7 @@ depends=(
)
makedepends=(
'asar'
+ 'npm'
)
source=(
@@ -25,18 +26,16 @@ source=(
com.usebruno.app.Bruno.desktop
)
-sha256sums=(
- 'e4c3f2e4aa01537d4e336802acd8e979fec9bbb00fd99996216b0e9264f0087f' # bruno
- '7bad0d66e67fdaaf99d1b7b32ba2f119b7d6dba12ecfdb398c39ee3c81bbe051' # bruno.desktop
-)
+sha256sums=('4e964b5b053318d7604362aabc9b88ae2a4d58e39dadbe14e8083d7d1e38f987'
+ '7bad0d66e67fdaaf99d1b7b32ba2f119b7d6dba12ecfdb398c39ee3c81bbe051')
prepare() {
cd "${_pkgname}-${pkgver}"
- # disabling husky however I can since I'm not in a git repository
+ # Try our hardest to disable Husky
sed -i -e 's/"husky":.*//g' -e 's/"husky install"/"true"/g' package.json
- npm install --legacy-peer-deps
+ npm install --cache "${srcdir/npm-cache}" --legacy-peer-deps
}
build() {
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..28363e2e701d
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+updpkgsums
+makepkg --printsrcinfo > .SRCINFO