summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-11-14 11:26:51 -0300
committerDaniel Bermond2022-11-14 11:26:51 -0300
commitff82ca9d7ed17c6e3d7d6c8178d945a9ce24fbe7 (patch)
tree5ed61bc3c971738d6d6ccd0260043d284d32a3f2
parent358de11047a2481529cc22e33b1138db883552a3 (diff)
downloadaur-brunsli.tar.gz
Fix git submodules. Cosmetic changes.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4211237f9a4..7517fec45db1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = brunsli
pkgdesc = Lossless JPEG repacker
pkgver = 0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/google/brunsli/
arch = x86_64
license = MIT
@@ -10,7 +10,7 @@ pkgbase = brunsli
depends = gcc-libs
source = git+https://github.com/google/brunsli.git#tag=v0.1
source = git+https://github.com/google/brotli.git
- source = git+https://github.com/google/googletest
+ source = git+https://github.com/google/googletest.git
source = git+https://github.com/google/highwayhash.git
sha256sums = SKIP
sha256sums = SKIP
@@ -18,4 +18,3 @@ pkgbase = brunsli
sha256sums = SKIP
pkgname = brunsli
-
diff --git a/PKGBUILD b/PKGBUILD
index 736006882310..5dd09f072906 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=brunsli
pkgver=0.1
-pkgrel=1
+pkgrel=2
pkgdesc='Lossless JPEG repacker'
arch=('x86_64')
url='https://github.com/google/brunsli/'
@@ -11,7 +11,7 @@ depends=('gcc-libs')
makedepends=('git' 'cmake')
source=("git+https://github.com/google/brunsli.git#tag=v${pkgver}"
'git+https://github.com/google/brotli.git'
- 'git+https://github.com/google/googletest'
+ 'git+https://github.com/google/googletest.git'
'git+https://github.com/google/highwayhash.git')
sha256sums=('SKIP'
'SKIP'
@@ -19,12 +19,11 @@ sha256sums=('SKIP'
'SKIP')
prepare() {
- cd brunsli
- git submodule init
- git config --local submodule.third_party/brotli.url "${srcdir}/brotli"
- git config --local submodule.third_party/googletest.url "${srcdir}/googletest"
- git config --local submodule.third_party/highwayhash.url "${srcdir}/highwayhash"
- git submodule update
+ git -C brunsli submodule init
+ git -C brunsli config --local submodule.third_party/brotli.url "${srcdir}/brotli"
+ git -C brunsli config --local submodule.third_party/googletest.url "${srcdir}/googletest"
+ git -C brunsli config --local submodule.third_party/highwayhash.url "${srcdir}/highwayhash"
+ git -C brunsli -c protocol.file.allow='always' submodule update
}
build() {