summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicklas Botö2020-10-18 23:14:56 +0200
committerNicklas Botö2020-10-18 23:14:56 +0200
commite272e3b0e7170a5cad9fb37096e8afcc7097d626 (patch)
treec74fd2ce8192d55caf9dc71db719c30edad02421
downloadaur-bruski-git.tar.gz
Changed name with git suffix
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a35b94a61131
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bruski-git
+ pkgdesc = The BruSKI language compiler and platform
+ pkgver = 1.1.r236.0506501
+ pkgrel = 1
+ url = https://github.com/NicklasBoto/BruSKI.git
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = make
+ makedepends = stack
+ source = git+https://github.com/NicklasBoto/BruSKI.git
+ md5sums = SKIP
+
+pkgname = bruski-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a50cf0c3b8cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Nicklas Botö <bruski@nicklasbotö.se>
+pkgname=bruski-git
+pkgver=1.1.r236.0506501
+pkgrel=1
+pkgdesc="The BruSKI language compiler and platform"
+arch=(x86_64)
+url="https://github.com/NicklasBoto/BruSKI.git"
+license=('GPL')
+depends=()
+makedepends=(git make stack)
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/BruSKI"
+ printf "1.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/BruSKI"
+
+ install -d "${pkgdir}/usr/lib/bruski"
+ install -D src/Prelude/*.bru "${pkgdir}/usr/lib/bruski/"
+
+ echo "-- Path to standard library" >> src/Config.hs
+ echo 'preludePath = "/usr/lib/bruski/"' >> src/Config.hs
+
+ stack install --local-bin-path "${pkgdir}/usr/bin"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+
+ make DESTDIR="$pkgdir/" install
+}