aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Scheirer2020-04-17 14:54:02 -0400
committerMatt Scheirer2020-04-17 14:54:02 -0400
commiteb92fba3c2dd8a32d61aa2bb6004c6b72d7d7480 (patch)
tree0d130a33b6f618c542ff2543814afb1c7d344c95
parent085b1ac228d2a8e1d10a5cfa38f55117fe64f953 (diff)
downloadaur-eb92fba3c2dd8a32d61aa2bb6004c6b72d7d7480.tar.gz
Support opening wads with brutal doom
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
-rwxr-xr-xbrutal-doom6
-rw-r--r--brutal-doom.desktop8
4 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28ba8056b0c2..3bc22e42e95f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = brutal-doom
pkgdesc = Brutal Doom via the GzDoom engine.
pkgver = 21
- pkgrel = 2
+ pkgrel = 3
url = http://www.moddb.com/mods/brutal-doom
arch = any
license = GPL3
@@ -15,12 +15,12 @@ pkgbase = brutal-doom
source = gzdoom.ini
source = brutal-doom.png
source = brutal-doom.desktop
- sha1sums = 3260fccd428d9b8e9327e36978f80dc48fe31000
- sha1sums = de01ec06563a442ed04649f5062cd1b61cfc1917
- sha1sums = 0255b97eb04619e43d65774eaccc257863ecdb36
- sha1sums = 8207776f36fd46a0ee85b72b047e79484e2079f3
- sha1sums = 0259b3c20a2749f28c8add5cd55755c51bd2cef6
- sha1sums = 1f9e71edef0131d24f0aced422ba7b7cb8573a1c
+ sha256sums = d4c901a92757c9ae7d3a8437172e4669fe0a3e939229160c26f99269b704a227
+ sha256sums = 7d285d342ba27a432e7b795fa1b7656bb9bd7cb9680105a8d7d565677fc56a9f
+ sha256sums = 91f58cc1c670c5408100305463960c195200f8ad35619eedd2c531dc9c60badf
+ sha256sums = aee3fd4580da214b9c981534928de5dfef65461c459d5c56dd343bf579912b75
+ sha256sums = 905cc17cccca54d3c4da821cdd974c8540deacd42534077ca4da9092c4a96074
+ sha256sums = 9c2b7a7cd048fd4e6a7fe65b93376cf2d9a9fa4564b8f3cc7b2baac38ea8e5f3
pkgname = brutal-doom
diff --git a/PKGBUILD b/PKGBUILD
index a448f67f6675..c1569087a7b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=brutal-doom
pkgver=21
-pkgrel=2
+pkgrel=3
pkgdesc="Brutal Doom via the GzDoom engine."
arch=(any)
url="http://www.moddb.com/mods/brutal-doom"
@@ -20,13 +20,13 @@ source=(
'brutal-doom.desktop'
)
noextract=('brutalv21.pk3')
-sha1sums=(
- '3260fccd428d9b8e9327e36978f80dc48fe31000'
- 'de01ec06563a442ed04649f5062cd1b61cfc1917'
- '0255b97eb04619e43d65774eaccc257863ecdb36'
- '8207776f36fd46a0ee85b72b047e79484e2079f3'
- '0259b3c20a2749f28c8add5cd55755c51bd2cef6'
- '1f9e71edef0131d24f0aced422ba7b7cb8573a1c'
+sha256sums=(
+ 'd4c901a92757c9ae7d3a8437172e4669fe0a3e939229160c26f99269b704a227'
+ '7d285d342ba27a432e7b795fa1b7656bb9bd7cb9680105a8d7d565677fc56a9f'
+ '91f58cc1c670c5408100305463960c195200f8ad35619eedd2c531dc9c60badf'
+ 'aee3fd4580da214b9c981534928de5dfef65461c459d5c56dd343bf579912b75'
+ '905cc17cccca54d3c4da821cdd974c8540deacd42534077ca4da9092c4a96074'
+ '9c2b7a7cd048fd4e6a7fe65b93376cf2d9a9fa4564b8f3cc7b2baac38ea8e5f3'
)
package() {
diff --git a/brutal-doom b/brutal-doom
index 75a7ae9508b0..648ed6c0691d 100755
--- a/brutal-doom
+++ b/brutal-doom
@@ -11,4 +11,8 @@ if [ ! -f "$XDG_CONFIG_HOME/brutal-doom/gzdoom.ini" ]; then
cp "/usr/share/games/brutal-doom/gzdoom.ini" "$XDG_CONFIG_HOME/brutal-doom/"
fi
-gzdoom -config "$XDG_CONFIG_HOME/brutal-doom/gzdoom.ini"
+for arg in "$@"; do
+ args="$args -file $arg"
+done
+
+gzdoom -config "$XDG_CONFIG_HOME/brutal-doom/gzdoom.ini" $args
diff --git a/brutal-doom.desktop b/brutal-doom.desktop
index 29b8cb76dece..bbc2bf9c608c 100644
--- a/brutal-doom.desktop
+++ b/brutal-doom.desktop
@@ -3,9 +3,9 @@ Version=1.0
Name=Brutal Doom
GenericName=Brutal Doom
Type=Application
-Icon=/usr/share/pixmaps/brutal-doom.png
-Exec=brutal-doom
+Icon=brutal-doom
+Exec=brutal-doom %F
+MimeType=application/x-doom-wad;
Keywords=game;
Terminal=false
-Categories=Game
-
+Categories=Game;ActionGame;