summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortasidus2015-08-03 19:08:32 +0300
committertasidus2015-08-03 19:08:32 +0300
commita5a5729d742ab457e258b738c1ec2974f091eb89 (patch)
treedaa9ad5b57f50faec8073c98030af928a70fe2c2
downloadaur-a5a5729d742ab457e258b738c1ec2974f091eb89.tar.gz
aur3 -> aur4 migration
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d398f217aed4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bs
+ pkgdesc = The classic game of Battleships against the computer. Ncurses.
+ pkgver = 2.9
+ pkgrel = 1
+ url = http://www.catb.org/~esr/bs/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = ncurses
+ source = http://www.catb.org/~esr/bs//bs-2.9.tar.gz
+ md5sums = 4d4eec59c1789cffacf367d993e724f4
+
+pkgname = bs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df905bcf266a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Tasos Latsas <tlatsas@gmx.com>
+# Contributor: Patrick Palka <patrick@parcs.ath.cx>
+# Contributor: damir <damir@archlinux.org>
+# Development: http://closure.ath.cx/aur-dev
+
+pkgname=bs
+pkgver=2.9
+pkgrel=1
+pkgdesc="The classic game of Battleships against the computer. Ncurses."
+arch=('i686' 'x86_64')
+url="http://www.catb.org/~esr/bs/"
+license=('GPL2')
+depends=('ncurses')
+source=($url/$pkgname-$pkgver.tar.gz)
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 bs $pkgdir/usr/bin/bs
+ install -Dm644 bs.6 $pkgdir/usr/share/man/man6/bs.6
+}
+
+md5sums=('4d4eec59c1789cffacf367d993e724f4')