summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2016-12-08 10:59:11 -0500
committerTed Alff2016-12-08 10:59:11 -0500
commitfaee941f096a5c625938e02e1081857a6788ae3a (patch)
treea3e732726d93e1f95d5494439c26a00397595125
parent10bd50e6a0b9984467141d5edc46061c7e765814 (diff)
downloadaur-faee941f096a5c625938e02e1081857a6788ae3a.tar.gz
Adopted and applied Makefile fix.
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile_fix.patch21
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd7fc6e24372..6495830cc9d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Dec 8 15:58:53 UTC 2016
pkgbase = bs
pkgdesc = The classic game of Battleships against the computer. Ncurses.
pkgver = 2.10
- pkgrel = 2
+ pkgrel = 3
url = https://www.catb.org/~esr/bs/
arch = i686
arch = x86_64
@@ -9,7 +11,9 @@ pkgbase = bs
depends = ncurses
depends = hicolor-icon-theme
source = http://www.catb.org/~esr/bs/bs-2.10.tar.gz
+ source = Makefile_fix.patch
sha256sums = 1f8c1541fd13f481ff96df26d668658a7465da064801ae22ee584bd50f3a3107
+ sha256sums = a09e386c70ecedf421d38907fbe91364f880c894408ba82051f55104852551c5
pkgname = bs
diff --git a/Makefile_fix.patch b/Makefile_fix.patch
new file mode 100644
index 000000000000..b33665fc73a5
--- /dev/null
+++ b/Makefile_fix.patch
@@ -0,0 +1,21 @@
+diff -Naur ./bs-2.10.orig/Makefile ./bs-2.10/Makefile
+--- ./bs-2.10.orig/Makefile 2016-12-08 10:54:14.164589590 -0500
++++ ./bs-2.10/Makefile 2016-12-08 10:54:46.243780672 -0500
+@@ -5,7 +5,7 @@
+ CC = gcc
+
+ # DESTDIR support
+-DESTDIR =
++DESTDIR =
+
+ bs: bs.c
+ $(CC) $(CFLAGS) -o bs bs.c -lncurses
+@@ -35,7 +35,7 @@
+ install -m 0644 bs.xml $(DESTDIR)/usr/share/appdata/
+
+ uninstall:
+- rm -f /usr/bin/bs /usr/share/man/man6/bs.6
++ rm -f $(DESTDIR)/usr/bin/bs $(DESTDIR)/usr/share/man/man6/bs.6
+
+ SOURCES = README COPYING NEWS control bs.c Makefile bs.xml battleship.png bs.desktop
+
diff --git a/PKGBUILD b/PKGBUILD
index 34aa2bfe2ba7..b9515441f9e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
-# Maintainer: Tasos Latsas <tlatsas@gmx.com>
+# Maintainer: twa022 <twa022 at gmail dot com>
+# Contrinutor: Tasos Latsas <tlatsas@gmx.com>
# Contributor: Patrick Palka <patrick@parcs.ath.cx>
# Contributor: damir <damir@archlinux.org>
# Development: http://closure.ath.cx/aur-dev
pkgname=bs
pkgver=2.10
-pkgrel=2
+pkgrel=3
pkgdesc="The classic game of Battleships against the computer. Ncurses."
arch=('i686' 'x86_64')
url="https://www.catb.org/~esr/bs/"
license=('GPL2')
depends=('ncurses' 'hicolor-icon-theme')
-source=("http://www.catb.org/~esr/bs/bs-$pkgver.tar.gz")
-sha256sums=('1f8c1541fd13f481ff96df26d668658a7465da064801ae22ee584bd50f3a3107')
+source=("http://www.catb.org/~esr/bs/bs-$pkgver.tar.gz"
+ 'Makefile_fix.patch')
+sha256sums=('1f8c1541fd13f481ff96df26d668658a7465da064801ae22ee584bd50f3a3107'
+ 'a09e386c70ecedf421d38907fbe91364f880c894408ba82051f55104852551c5')
-build() {
- cd $pkgname-$pkgver
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -uNp2 -r- -i ../Makefile_fix.patch
+}
+build() {
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd $pkgname-$pkgver
-
+ cd "${pkgname}-${pkgver}"
make DESTDIR="$pkgdir" install
}