summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Meunier2018-12-07 18:04:22 +0100
committerGuillaume Meunier2018-12-07 18:04:22 +0100
commitdce02480cce391d74d84d43ac3144ff5fb612766 (patch)
tree3af7052183ee80861d986b36859089f771d43958
parentfade03e3febc5c1952766b468ffa98ab1ecf6207 (diff)
downloadaur-dce02480cce391d74d84d43ac3144ff5fb612766.tar.gz
Don't strip debug symbols in CMakeLists
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
-rw-r--r--dont-strip-symbols.patch33
-rw-r--r--install-dir.patch2
4 files changed, 54 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ebacc3ef608..94fc6bbc9647 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bsf-git
pkgdesc = A C++ library that aims to provide a unified foundation for the development of real-time graphical applications, whether games, engines or tools
- pkgver = r4602.b5807447c
+ pkgver = r4615.c46bcf338
pkgrel = 1
url = https://www.bsframework.io/
arch = x86_64
@@ -11,14 +11,18 @@ pkgbase = bsf-git
makedepends = ninja
source = git+https://github.com/GameFoundry/bsf.git
source = install-dir.patch
+ source = dont-strip-symbols.patch
source = https://data.banshee3d.com/bsfCompiledData_Master_5.zip
source = https://data.banshee3d.com/bsfData_Master_6.zip
source = https://data.banshee3d.com/bsfDependencies_Linux_Master_8.zip
+ source = https://data.banshee3d.com/bsfDocImagesData_Master_2.zip
sha256sums = SKIP
- sha256sums = 3ebcebdbe4d5bad832a47109b09f6d9bcd3e02b7a0bb9be2301c8bd630ed706b
+ sha256sums = ee326f6eb0a97e7b306181a34675b5fadf55ce69bdec1c738600bb9d15908e91
+ sha256sums = 68c27be79da735c7aa2cdc30558d30b73a61eb6d52d00d4b0bd085c9fc96fc87
sha256sums = 49b419403f4f85e189832f3b89c78c037e7b531541bb67b130764f33c7306224
sha256sums = 3b5e087e200e786ab1a0b79d6f3cd04d4c70fde9337dc8082a13479f477d1025
sha256sums = 60c53790eda57495fefdad2bcc4a6a78198a330e70aeec71abc213edcc8b7036
+ sha256sums = e9d3793f87c4ff0a36f3574ecd070e4b6b25c567a063e3042d2dc5883636f011
pkgname = bsf-git
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 826d2aa442aa..d23180cb1433 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=(bsf-git bsf-git-docs)
pkgbase=bsf-git
_pkgname=bsf
-pkgver=r4602.b5807447c
+pkgver=r4615.c46bcf338
pkgrel=1
epoch=
pkgdesc="A C++ library that aims to provide a unified foundation for the development of real-time graphical applications, whether games, engines or tools"
@@ -19,22 +19,27 @@ options=()
install=
changelog=
-source=("git+https://github.com/GameFoundry/bsf.git"
- "install-dir.patch"
- "https://data.banshee3d.com/bsfCompiledData_Master_5.zip"
- "https://data.banshee3d.com/bsfData_Master_6.zip"
- "https://data.banshee3d.com/bsfDependencies_Linux_Master_8.zip")
+source=('git+https://github.com/GameFoundry/bsf.git'
+ 'install-dir.patch'
+ 'dont-strip-symbols.patch'
+ 'https://data.banshee3d.com/bsfCompiledData_Master_5.zip'
+ 'https://data.banshee3d.com/bsfData_Master_6.zip'
+ 'https://data.banshee3d.com/bsfDependencies_Linux_Master_8.zip'
+ 'https://data.banshee3d.com/bsfDocImagesData_Master_2.zip')
noextract=()
sha256sums=('SKIP'
- '3ebcebdbe4d5bad832a47109b09f6d9bcd3e02b7a0bb9be2301c8bd630ed706b'
+ 'ee326f6eb0a97e7b306181a34675b5fadf55ce69bdec1c738600bb9d15908e91'
+ '68c27be79da735c7aa2cdc30558d30b73a61eb6d52d00d4b0bd085c9fc96fc87'
'49b419403f4f85e189832f3b89c78c037e7b531541bb67b130764f33c7306224'
'3b5e087e200e786ab1a0b79d6f3cd04d4c70fde9337dc8082a13479f477d1025'
- '60c53790eda57495fefdad2bcc4a6a78198a330e70aeec71abc213edcc8b7036')
+ '60c53790eda57495fefdad2bcc4a6a78198a330e70aeec71abc213edcc8b7036'
+ 'e9d3793f87c4ff0a36f3574ecd070e4b6b25c567a063e3042d2dc5883636f011')
validpgpkeys=()
prepare() {
cp -r Data bsf/
cp -r Dependencies bsf/
+ cp -r Documentation bsf/
cp -r Raw bsf/Data
rm -rf "$_pkgname"/Dependencies/OpenAL
@@ -46,6 +51,7 @@ prepare() {
rm -rf "$_pkgname"/Dependencies/freeimg
patch -d bsf -p1 < install-dir.patch
+ patch -d bsf -p1 < dont-strip-symbols.patch
}
pkgver() {
diff --git a/dont-strip-symbols.patch b/dont-strip-symbols.patch
new file mode 100644
index 000000000000..0a1ad94a113b
--- /dev/null
+++ b/dont-strip-symbols.patch
@@ -0,0 +1,33 @@
+diff --git a/Source/CMake/HelperMethods.cmake b/Source/CMake/HelperMethods.cmake
+index 9577b6c8e..90ec58df6 100644
+--- a/Source/CMake/HelperMethods.cmake
++++ b/Source/CMake/HelperMethods.cmake
+@@ -331,8 +331,6 @@ function(strip_symbols targetName outputFilename)
+ endfunction()
+
+ function(install_bsf_target targetName)
+- strip_symbols(${targetName} symbolsFile)
+-
+ install(
+ TARGETS ${targetName}
+ EXPORT bsf
+@@ -340,19 +338,6 @@ function(install_bsf_target targetName)
+ LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib
+ )
+-
+- if(MSVC)
+- install(
+- FILES $<TARGET_PDB_FILE:${targetName}>
+- DESTINATION bin
+- OPTIONAL
+- )
+- else()
+- install(
+- FILES ${symbolsFile}
+- DESTINATION lib
+- OPTIONAL)
+- endif()
+ endfunction()
+
+ function(copyBsfBinaries target srcDir)
diff --git a/install-dir.patch b/install-dir.patch
index e3af1871453e..545a6b3a67e2 100644
--- a/install-dir.patch
+++ b/install-dir.patch
@@ -27,7 +27,7 @@ diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 02ba71c5a..ebaac189c 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
-@@ -193,8 +193,8 @@ check_and_update_builtin_assets(bsfCompiled ${BSF_SOURCE_DIR}/../Data Data ${COM
+@@ -195,8 +195,8 @@ check_and_update_builtin_assets(bsfCompiled ${BSF_SOURCE_DIR}/../Data Data ${COM
## Install
install(