summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElaina Martineau2019-03-07 18:19:09 -0700
committerElaina Martineau2019-03-07 18:19:09 -0700
commitc105baebea5b9b94334a4baf5cb91b0e94f66364 (patch)
tree4c3b1d62c345db9215dd35524a2b05419ab1e502
downloadaur-c105baebea5b9b94334a4baf5cb91b0e94f66364.tar.gz
Initial commit for bsnes v107
-rw-r--r--.SRCINFO20
-rwxr-xr-xPKGBUILD42
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4dd43067c3c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = bsnes
+ pkgdesc = Super Nintendo emulator focusing on performance, features, and ease of use.
+ pkgver = 107
+ pkgrel = 1
+ url = https://byuu.org/emulation/bsnes/
+ arch = x86_64
+ license = GPL3
+ depends = libpulse
+ depends = gtksourceview2
+ depends = libxv
+ depends = libao
+ depends = openal
+ depends = sdl2
+ conflicts = bsnes-classic
+ conflicts = bsnes-plus
+ source = https://download.byuu.org/bsnes_v107-source.7z
+ sha256sums = 7b7fa745ce593f9912ce116bdf009cd2e70eb034cd7186264c4abedb87a5da36
+
+pkgname = bsnes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..cc439be29f4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Elaina Martineau <elainamartineau@gmail.com>
+
+pkgname=bsnes
+pkgver=107
+pkgrel=1
+pkgdesc='Super Nintendo emulator focusing on performance, features, and ease of use.'
+arch=('x86_64')
+url='https://byuu.org/emulation/bsnes/'
+license=('GPL3')
+groups=()
+depends=('libpulse' 'gtksourceview2' 'libxv' 'libao' 'openal' 'sdl2')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=('bsnes-classic' 'bsnes-plus')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://download.byuu.org/""$pkgname""_v""$pkgver""-source.7z")
+noextract=()
+sha256sums=('7b7fa745ce593f9912ce116bdf009cd2e70eb034cd7186264c4abedb87a5da36')
+
+prepare() {
+ cd "$pkgname""_v""$pkgver""-source"
+
+ # Allow us to build as root
+ sed -i '37 d; 38 d; 39 s/else //' higan/target-bsnes/GNUmakefile
+}
+
+build() {
+ cd "$pkgname""_v""$pkgver""-source"
+
+ make -C higan
+}
+
+package() {
+ cd "$pkgname""_v""$pkgver""-source"
+
+ make -C higan prefix="$pkgdir/usr" install
+}