summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2015-10-29 03:09:05 +1300
committerVaporeon2015-10-29 03:09:05 +1300
commit5c4d5a60126be904043039271118fdd15f201929 (patch)
tree9a8f14feb65081afd558bbd6f2f55a1acf9725ea
parentb8e3cb1b91f3b1a3b062387f9fcbd2b7e6327524 (diff)
downloadaur-5c4d5a60126be904043039271118fdd15f201929.tar.gz
use zenity
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--bsnes10
3 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fc9195dee77..add8f3410ca5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bsnes-classic-git
pkgdesc = SNES emulator with Qt GUI and debugger
- pkgver = 0.73r62.c134d41
+ pkgver = 0.73r75.fb26195
pkgrel = 1
url = https://github.com/awjackson/bsnes-classic
arch = i686
@@ -13,14 +13,14 @@ pkgbase = bsnes-classic-git
depends = openal
depends = qt4
depends = sdl
- depends = xdialog
+ depends = zenity
provides = bsnes-classic
conflicts = bsnes-classic
conflicts = bsnes-plus
source = git+https://github.com/awjackson/bsnes-classic.git
source = bsnes
sha256sums = SKIP
- sha256sums = d3630df281d533312821bff1d27126df437534e39f37c7d42c1cd347d6d240b5
+ sha256sums = a51e0c313e1f809aaa2f5cc8c63bd050618053db83a23e76c1a0c5e3d213c2b7
pkgname = bsnes-classic-git
diff --git a/PKGBUILD b/PKGBUILD
index 98e5be0a8cb8..8416a6ad4ab9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# Maintainer: Duck Hunt <vaporeon@tfwno.gf>
+# Maintainer: Vaporeon <vaporeon@tfwno.gf>
pkgname=bsnes-classic-git
-pkgver=0.73r62.c134d41
+pkgver=0.73r75.fb26195
pkgrel=1
pkgdesc='SNES emulator with Qt GUI and debugger'
arch=('i686' 'x86_64')
url='https://github.com/awjackson/bsnes-classic'
license=('GPL3')
-depends=('libao' 'libpulse' 'openal' 'qt4' 'sdl' 'xdialog')
+depends=('libao' 'libpulse' 'openal' 'qt4' 'sdl' 'zenity')
makedepends=('mesa' 'git')
source=("git+${url}.git"
'bsnes')
sha256sums=('SKIP'
- 'd3630df281d533312821bff1d27126df437534e39f37c7d42c1cd347d6d240b5')
+ 'a51e0c313e1f809aaa2f5cc8c63bd050618053db83a23e76c1a0c5e3d213c2b7')
conflicts=('bsnes-classic' 'bsnes-plus')
provides=('bsnes-classic')
@@ -51,4 +51,4 @@ package() {
for p in {accuracy,compatibility,performance}; do
install -m 755 bsnes/out/bsnes-$p "${pkgdir}"/usr/bin/
done
-} \ No newline at end of file
+}
diff --git a/bsnes b/bsnes
index 20fb57021421..0177b95fb234 100644
--- a/bsnes
+++ b/bsnes
@@ -1,10 +1,6 @@
#!/bin/sh
-# Check for profiles and prompt user with a GUI
-[ -e /usr/bin/bsnes-accuracy ] && tag1=accuracy
-[ -e /usr/bin/bsnes-compatibility ] && tag2=compatibility
-[ -e /usr/bin/bsnes-performance ] && tag3=performance
-profile="$(Xdialog --stdout --no-tags --title "bsnes-classic" --radiolist "Choose a profile" 0 0 0 "$tag1" "Accuracy" off "$tag2" "Compatibility" off "$tag3" "Performance" off)"
-
+# Prompt for profile
+profile="$(zenity --list --radiolist --title 'Please select a profile' --column '' --column '' FALSE 'accuracy' TRUE 'compatibility' FALSE 'performance')"
# Launch selected profile
-exec bsnes-$profile "$@" \ No newline at end of file
+[[ -n $profile ]] && exec bsnes-$profile "$@"