summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordekart8112020-01-13 18:34:58 +0100
committerdekart8112020-01-13 18:34:58 +0100
commitc1fc2a931f45f252659cfdf101629f54414074a3 (patch)
tree8a9f8530a731ad83425485be7ec34d3ba58e7acd
parent7da1a39fdca3e8b3b56ae2651001f0fea877ccb3 (diff)
downloadaur-c1fc2a931f45f252659cfdf101629f54414074a3.tar.gz
Update to beta10 and added git as build dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
-rw-r--r--bsnes-hd.patch16
3 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 287a02d6a47f..5493d9946cfb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = bsnes-hd
pkgdesc = Nintendo SNES emulator, featuring HD Mode 7 and Widescreen.
- pkgver = beta9.r0.g9f9cb26
+ pkgver = beta10.r0.g917673f
pkgrel = 1
url = https://github.com/DerKoun/bsnes-hd
arch = x86_64
license = GPL3
+ makedepends = git
depends = alsa-lib
depends = cairo
depends = gcc-libs
diff --git a/PKGBUILD b/PKGBUILD
index 5b964cd121a2..8a613a50eb56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: dekart811
pkgname=bsnes-hd
-_gitver=beta9
-pkgver=beta9.r0.g9f9cb26
+_gitver=beta10
+pkgver=beta10.r0.g917673f
pkgrel=1
pkgdesc='Nintendo SNES emulator, featuring HD Mode 7 and Widescreen.'
arch=('x86_64')
url='https://github.com/DerKoun/bsnes-hd'
license=('GPL3')
depends=('alsa-lib' 'cairo' 'gcc-libs' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk2' 'gtksourceview2' 'libao' 'libgl' 'libpulse' 'libx11' 'libxext' 'libxv' 'openal' 'pango' 'sdl' 'libudev.so' 'sdl2')
+makedepends=('git')
conflicts=('bsnes' 'bsnes-classic' 'higan-bsnes')
source=(git+https://github.com/DerKoun/bsnes-hd.git)
md5sums=('SKIP')
@@ -19,12 +20,11 @@ pkgver() {
}
prepare() {
+ cp "../${pkgname}.patch" "${pkgname}/"
cd "${pkgname}"
git checkout tags/"${_gitver}" -b "${_gitver}"
- # root issue in package
- cd "./bsnes/target-bsnes"
- sed -i "37,38d" GNUmakefile
- sed -i '37s/^.....//' GNUmakefile
+ # fix root issue in package
+ git apply "${pkgname}.patch"
}
build() {
diff --git a/bsnes-hd.patch b/bsnes-hd.patch
new file mode 100644
index 000000000000..4839a083ac56
--- /dev/null
+++ b/bsnes-hd.patch
@@ -0,0 +1,16 @@
+diff --git a/bsnes/target-bsnes/GNUmakefile b/bsnes/target-bsnes/GNUmakefile
+index 4c67bde..5ab1f0e 100644
+--- a/bsnes/target-bsnes/GNUmakefile
++++ b/bsnes/target-bsnes/GNUmakefile
+@@ -39,10 +39,7 @@ endif
+ verbose: hiro.verbose ruby.verbose nall.verbose all;
+
+ install: all
+-ifeq ($(platform),windows)
+-else ifeq ($(shell id -un),root)
+- $(error "make install should not be run as root")
+-else ifeq ($(platform),macos)
++ifeq ($(platform),macos)
+ mkdir -p ~/Library/Application\ Support/$(name)/
+ mkdir -p ~/Library/Application\ Support/$(name)/Database/
+ mkdir -p ~/Library/Application\ Support/$(name)/Firmware/