summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-04-06 14:52:01 -0600
committerMark Wagie2024-04-06 14:52:01 -0600
commit2c1ad1fa99155dd6ad2b733cceef3454e3bb0c54 (patch)
treebc8c315a2d7789b5c58fbd4050ab4a537d22b93f
downloadaur-2c1ad1fa99155dd6ad2b733cceef3454e3bb0c54.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD36
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b96f1181168c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bsnes-highscore-git
+ pkgdesc = Highscore port of BSNES
+ pkgver = r3019.1ae043e3
+ pkgrel = 1
+ url = https://github.com/alice-mkh/bsnes
+ arch = x86_64
+ license = GPL-3.0-or-later
+ makedepends = git
+ depends = libhighscore-git
+ provides = bsnes-highscore
+ conflicts = bsnes-highscore
+ source = git+https://github.com/alice-mkh/bsnes.git
+ sha256sums = SKIP
+
+pkgname = bsnes-highscore-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d4534237f9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=bsnes-highscore-git
+pkgver=r3019.1ae043e3
+pkgrel=1
+pkgdesc="Highscore port of BSNES"
+arch=('x86_64')
+url="https://github.com/alice-mkh/bsnes"
+license=('GPL-3.0-or-later')
+depends=('libhighscore-git')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/alice-mkh/bsnes.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd bsnes
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd bsnes
+ make -C bsnes \
+ target=highscore \
+ binary=library \
+ build=performance \
+ local=false \
+ platform=linux
+}
+
+package() {
+ cd bsnes
+ install -Dm755 "bsnes/out/${pkgname%-git}.so" -t \
+ "$pkgdir/usr/lib/highscore/cores/"
+ install -m644 bsnes/target-highscore/bsnes.highscore -t \
+ "$pkgdir/usr/lib/highscore/cores/"
+}