summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2023-06-19 02:23:37 +1200
committerVaporeon2023-06-19 02:23:37 +1200
commit4bb7e1bc8afb7ab0f1fc3c9913e81ac2bb56c5a4 (patch)
treea55c900ba430f410c566d1e9463ec44ea277c5d7
parent7a7a92de0353f97a0938b4a8b915cd96e3265dbb (diff)
downloadaur-4bb7e1bc8afb7ab0f1fc3c9913e81ac2bb56c5a4.tar.gz
Use updated source
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD30
-rw-r--r--package.patch23
3 files changed, 38 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99dc4831fa6a..bb1ae151fe39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,25 @@
pkgbase = bsnes-qt5
- pkgdesc = Super Nintendo emulator focusing on performance, features, and ease of use (Qt 5).
- pkgver = 115
- pkgrel = 2
+ pkgdesc = Super Nintendo emulator focusing on performance, features, and ease of use. (Qt 5)
+ pkgver = 20230610
+ pkgrel = 1
url = https://byuu.org/emulation/bsnes/
arch = x86_64
license = GPL3
+ makedepends = git
depends = qt5-base
depends = libpulse
depends = libxv
depends = libao
depends = openal
depends = sdl2
+ provides = bsnes
+ conflicts = bsnes
conflicts = bsnes-classic
+ conflicts = bsnes-hd
conflicts = bsnes-plus
- conflicts = bsnes
- source = https://github.com/bsnes-emu/bsnes/archive/v115.tar.gz
+ source = bsnes::git+https://github.com/bsnes-emu/bsnes.git#commit=7ec3077079445c1ab591d542d475da5fa121632e
source = package.patch
- sha256sums = e51d25f95b8fbcb91470b3dc8844d87206b74f3a164e41e6db271601e0cff93c
- sha256sums = f391b8ce83ed1dfe93d83484464613de1fa1c454d69b02c5234efc9ef69fd3bb
+ sha256sums = SKIP
+ sha256sums = 12ed11da832105fd2424d4110a29b8bac546e36aceaf9196cc9290cef9706c85
pkgname = bsnes-qt5
-
diff --git a/PKGBUILD b/PKGBUILD
index 8243d56427b3..3ba5b674bb92 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,33 @@
# Contributor: Elaina Martineau <elainamartineau@gmail.com>
pkgname=bsnes-qt5
-pkgver=115
-pkgrel=2
-pkgdesc='Super Nintendo emulator focusing on performance, features, and ease of use (Qt 5).'
-arch=('x86_64')
+pkgver=20230610
+_commit=7ec3077079445c1ab591d542d475da5fa121632e
+pkgrel=1
+pkgdesc='Super Nintendo emulator focusing on performance, features, and ease of use. (Qt 5)'
+arch=(x86_64)
url='https://byuu.org/emulation/bsnes/'
-license=('GPL3')
-depends=('qt5-base' 'libpulse' 'libxv' 'libao' 'openal' 'sdl2')
-conflicts=('bsnes-classic' 'bsnes-plus' 'bsnes')
-source=("https://github.com/bsnes-emu/bsnes/archive/v${pkgver}.tar.gz" 'package.patch')
-sha256sums=('e51d25f95b8fbcb91470b3dc8844d87206b74f3a164e41e6db271601e0cff93c'
- 'f391b8ce83ed1dfe93d83484464613de1fa1c454d69b02c5234efc9ef69fd3bb')
+license=(GPL3)
+depends=(qt5-base libpulse libxv libao openal sdl2)
+makedepends=(git)
+conflicts=(bsnes bsnes-classic bsnes-hd bsnes-plus)
+provides=(bsnes)
+source=("bsnes::git+https://github.com/bsnes-emu/bsnes.git#commit=$_commit"
+ package.patch)
+sha256sums=('SKIP'
+ '12ed11da832105fd2424d4110a29b8bac546e36aceaf9196cc9290cef9706c85')
prepare() {
- cd "bsnes-${pkgver}"
+ cd "bsnes"
patch --forward --strip=1 --input="${srcdir}/package.patch" --ignore-whitespace
}
build() {
- cd "bsnes-${pkgver}"
+ cd "bsnes"
make -C bsnes hiro=qt5 moc=/usr/bin/moc
}
package() {
- cd "bsnes-${pkgver}"
+ cd "bsnes"
make -C bsnes hiro=qt5 moc=/usr/bin/moc prefix="${pkgdir}/usr" install
}
diff --git a/package.patch b/package.patch
index e1215507a360..889def69a09c 100644
--- a/package.patch
+++ b/package.patch
@@ -1,6 +1,6 @@
-diff --unified --recursive bsnes_v108-source.orig/bsnes/GNUmakefile bsnes_v108-source.new/bsnes/GNUmakefile
---- bsnes_v108-source.orig/bsnes/GNUmakefile 2019-03-10 01:42:30.163599022 -0700
-+++ bsnes_v108-source.new/bsnes/GNUmakefile 2019-03-10 01:45:20.179375447 -0700
+diff --unified --recursive a/bsnes/GNUmakefile b/bsnes/GNUmakefile
+--- a/bsnes/GNUmakefile 2023-06-10 21:22:40.000000000 +1200
++++ b/bsnes/GNUmakefile 2023-06-19 02:17:42.089821400 +1200
@@ -1,6 +1,9 @@
+flags = $(CFLAGS)
+options = $(LDFLAGS)
@@ -10,18 +10,17 @@ diff --unified --recursive bsnes_v108-source.orig/bsnes/GNUmakefile bsnes_v108-s
-build := performance
+build := release
openmp := true
+ local := true
flags += -I. -I..
-
-
-diff --unified --recursive bsnes_v113-source.orig/bsnes/target-bsnes/GNUmakefile bsnes_v113-source.new/bsnes/target-bsnes/GNUmakefile
---- bsnes_v113-source.orig/bsnes/target-bsnes/GNUmakefile 2019-12-11 12:19:18.782618740 -0700
-+++ bsnes_v113-source.new/bsnes/target-bsnes/GNUmakefile 2019-12-11 12:20:36.969034855 -0700
+diff --unified --recursive a/bsnes/target-bsnes/GNUmakefile b/bsnes/target-bsnes/GNUmakefile
+--- a/bsnes/target-bsnes/GNUmakefile 2023-06-10 21:22:40.000000000 +1200
++++ b/bsnes/target-bsnes/GNUmakefile 2023-06-19 02:17:42.106408200 +1200
@@ -40,8 +40,6 @@
-
+
install: all
ifeq ($(platform),windows)
-else ifeq ($(shell id -un),root)
-- $(error "make install should not be run as root")
+- $(error "make install should not be run as root")
else ifeq ($(platform),macos)
- mkdir -p ~/Library/Application\ Support/$(name)/
- mkdir -p ~/Library/Application\ Support/$(name)/Database/
+ mkdir -p ~/Library/Application\ Support/$(name)/
+ mkdir -p ~/Library/Application\ Support/$(name)/Database/