summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2019-07-30 20:02:12 +1200
committerVaporeon2019-07-30 20:02:12 +1200
commit77eacd1644f8bf5009982bbe2d501dd2607e0ecb (patch)
treea15b03305f9e738a62536a22c76919776de892ef
downloadaur-77eacd1644f8bf5009982bbe2d501dd2607e0ecb.tar.gz
Qt5 Build
-rw-r--r--.SRCINFO25
-rwxr-xr-xPKGBUILD33
-rw-r--r--package.patch29
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e8e5aa3170a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Tue Jul 30 08:01:43 UTC 2019
+pkgbase = bsnes-qt5
+ pkgdesc = Super Nintendo emulator focusing on performance, features, and ease of use.
+ pkgver = 108
+ pkgrel = 1
+ url = https://byuu.org/emulation/bsnes/
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ depends = libpulse
+ depends = libxv
+ depends = libao
+ depends = openal
+ depends = sdl2
+ conflicts = bsnes-classic
+ conflicts = bsnes-plus
+ conflicts = bsnes
+ source = https://download.byuu.org/bsnes_v108-source.7z
+ source = package.patch
+ sha256sums = 49c560b8438d0ea3942b1cd90ac3d4b5a33074eca77a0b24a7af463e87187bec
+ sha256sums = e800849a4e6c9b431578c2c55bfaab7b0619629ba34bd97f38bae64d5f2412d6
+
+pkgname = bsnes-qt5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..4973c6c8013b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Vaporeon <vaporeon@vaporeon.io>
+# Contributor: Elaina Martineau <elainamartineau@gmail.com>
+
+pkgname=bsnes-qt5
+pkgver=108
+pkgrel=1
+pkgdesc='Super Nintendo emulator focusing on performance, features, and ease of use.'
+arch=('x86_64')
+url='https://byuu.org/emulation/bsnes/'
+license=('GPL3')
+depends=('qt5-base' 'libpulse' 'libxv' 'libao' 'openal' 'sdl2')
+conflicts=('bsnes-classic' 'bsnes-plus' 'bsnes')
+source=("https://download.byuu.org/bsnes_v${pkgver//./r}-source.7z" 'package.patch')
+sha256sums=('49c560b8438d0ea3942b1cd90ac3d4b5a33074eca77a0b24a7af463e87187bec'
+ 'e800849a4e6c9b431578c2c55bfaab7b0619629ba34bd97f38bae64d5f2412d6')
+
+prepare() {
+ cd "bsnes_v${pkgver//./r}-source"
+
+ patch --forward --strip=1 --input="${srcdir}/package.patch"
+}
+
+build() {
+ cd "bsnes_v${pkgver//./r}-source"
+
+ make -C bsnes hiro=qt5 moc=/usr/bin/moc
+}
+
+package() {
+ cd "bsnes_v${pkgver//./r}-source"
+
+ make -C bsnes hiro=qt5 moc=/usr/bin/moc prefix="${pkgdir}/usr" install
+}
diff --git a/package.patch b/package.patch
new file mode 100644
index 000000000000..8512d3fd1f22
--- /dev/null
+++ b/package.patch
@@ -0,0 +1,29 @@
+diff --unified --recursive bsnes_v108-source.orig/bsnes/GNUmakefile bsnes_v108-source.new/bsnes/GNUmakefile
+--- bsnes_v108-source.orig/bsnes/GNUmakefile 2019-03-10 01:42:30.163599022 -0700
++++ bsnes_v108-source.new/bsnes/GNUmakefile 2019-03-10 01:45:20.179375447 -0700
+@@ -1,6 +1,9 @@
++flags = $(CFLAGS)
++options = $(LDFLAGS)
++
+ target := bsnes
+ binary := application
+-build := performance
++build := release
+ openmp := true
+ flags += -I. -I..
+
+
+diff --unified --recursive bsnes_v108-source.orig/bsnes/target-bsnes/GNUmakefile bsnes_v108-source.new/bsnes/target-bsnes/GNUmakefile
+--- bsnes_v108-source.orig/bsnes/target-bsnes/GNUmakefile 2019-03-10 01:51:07.601683406 -0700
++++ bsnes_v108-source.new/bsnes/target-bsnes/GNUmakefile 2019-03-10 01:52:00.013706440 -0700
+@@ -34,9 +34,7 @@
+ verbose: hiro.verbose ruby.verbose nall.verbose all;
+
+ install: all
+-ifeq ($(shell id -un),root)
+- $(error "make install should not be run as root")
+-else ifeq ($(platform),windows)
++ifeq ($(platform),windows)
+ else ifeq ($(platform),macos)
+ mkdir -p ~/Library/Application\ Support/$(name)/
+ cp -R out/$(name).app /Applications/$(name).app