summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2020-10-05 17:34:56 +1300
committerVaporeon2020-10-05 17:34:56 +1300
commit7a7a92de0353f97a0938b4a8b915cd96e3265dbb (patch)
tree3ba965ab3ecd4e167b8ed03b606a7f45428e69b0
parentb719d0b23b0a5b00caf23bd8877643e45d468baf (diff)
downloadaur-7a7a92de0353f97a0938b4a8b915cd96e3265dbb.tar.gz
update source link
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD14
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01e8a5522869..99dc4831fa6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Thu Mar 5 19:17:15 UTC 2020
pkgbase = bsnes-qt5
- pkgdesc = Super Nintendo emulator focusing on performance, features, and ease of use.
+ pkgdesc = Super Nintendo emulator focusing on performance, features, and ease of use (Qt 5).
pkgver = 115
- pkgrel = 1
+ pkgrel = 2
url = https://byuu.org/emulation/bsnes/
arch = x86_64
license = GPL3
@@ -16,9 +14,9 @@ pkgbase = bsnes-qt5
conflicts = bsnes-classic
conflicts = bsnes-plus
conflicts = bsnes
- source = https://byuu.org/download/bsnes/bsnes_v115-source.zip
+ source = https://github.com/bsnes-emu/bsnes/archive/v115.tar.gz
source = package.patch
- sha256sums = 4f983feda32f5f6e494f8ea5363fc97ebfe92e0d7b78d71ebe013ed7933e2386
+ sha256sums = e51d25f95b8fbcb91470b3dc8844d87206b74f3a164e41e6db271601e0cff93c
sha256sums = f391b8ce83ed1dfe93d83484464613de1fa1c454d69b02c5234efc9ef69fd3bb
pkgname = bsnes-qt5
diff --git a/PKGBUILD b/PKGBUILD
index a069f9195ab4..8243d56427b3 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,28 @@
pkgname=bsnes-qt5
pkgver=115
-pkgrel=1
-pkgdesc='Super Nintendo emulator focusing on performance, features, and ease of use.'
+pkgrel=2
+pkgdesc='Super Nintendo emulator focusing on performance, features, and ease of use (Qt 5).'
arch=('x86_64')
url='https://byuu.org/emulation/bsnes/'
license=('GPL3')
depends=('qt5-base' 'libpulse' 'libxv' 'libao' 'openal' 'sdl2')
conflicts=('bsnes-classic' 'bsnes-plus' 'bsnes')
-source=("https://byuu.org/download/bsnes/bsnes_v${pkgver//./r}-source.zip" 'package.patch')
-sha256sums=('4f983feda32f5f6e494f8ea5363fc97ebfe92e0d7b78d71ebe013ed7933e2386'
+source=("https://github.com/bsnes-emu/bsnes/archive/v${pkgver}.tar.gz" 'package.patch')
+sha256sums=('e51d25f95b8fbcb91470b3dc8844d87206b74f3a164e41e6db271601e0cff93c'
'f391b8ce83ed1dfe93d83484464613de1fa1c454d69b02c5234efc9ef69fd3bb')
prepare() {
- cd "bsnes_v${pkgver//./r}-source"
+ cd "bsnes-${pkgver}"
patch --forward --strip=1 --input="${srcdir}/package.patch" --ignore-whitespace
}
build() {
- cd "bsnes_v${pkgver//./r}-source"
+ cd "bsnes-${pkgver}"
make -C bsnes hiro=qt5 moc=/usr/bin/moc
}
package() {
- cd "bsnes_v${pkgver//./r}-source"
+ cd "bsnes-${pkgver}"
make -C bsnes hiro=qt5 moc=/usr/bin/moc prefix="${pkgdir}/usr" install
}