summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2023-12-01 18:04:54 +0100
committerJose Riha2023-12-01 18:04:54 +0100
commitad60d2332aa1d9cc33f6666d9b5dcd705d74222e (patch)
treeee2fa0d453d1f62f19eee837e23c5eb204696d99
parentb218c92ab4b25eca45e4604b7164a569ef4af257 (diff)
downloadaur-ad60d2332aa1d9cc33f6666d9b5dcd705d74222e.tar.gz
Switch source to github, update license
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c92509fee5b..65e26a275287 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = bsod
pkgdesc = Bsod displays the famous windows xp blue screen of death on the console
- pkgver = 0.1
- pkgrel = 6
- url = http://www.vanheusden.com/bsod/
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/folkertvanheusden/bsod
arch = i686
arch = x86_64
arch = armv7h
- license = GPL
+ license = public_domain
depends = ncurses
- source = http://web.archive.org/web/20150802072403/http://vanheusden.com/bsod/bsod-0.1.tgz
- md5sums = a95770f60bd77eda523f1aa0bfe3d01d
+ source = https://github.com/folkertvanheusden/bsod/archive/refs/tags/v0.2.tar.gz
+ md5sums = a58bd957bd98e0f74340d4ab7cee0f48
pkgname = bsod
-
diff --git a/PKGBUILD b/PKGBUILD
index f6af74ba1541..cec16036f10f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: jose <jose1711 [at] gmail (dot) com>
pkgname=bsod
-pkgver=0.1
-pkgrel=6
+pkgver=0.2
+pkgrel=1
pkgdesc="Bsod displays the famous windows xp blue screen of death on the console"
arch=('i686' 'x86_64' 'armv7h')
-url="http://www.vanheusden.com/bsod/"
-license=('GPL')
+url="https://github.com/folkertvanheusden/bsod"
+license=('public_domain')
depends=('ncurses')
-source=("http://web.archive.org/web/20150802072403/http://vanheusden.com/bsod/${pkgname}-${pkgver}.tgz")
-md5sums=('a95770f60bd77eda523f1aa0bfe3d01d')
+source=(https://github.com/folkertvanheusden/bsod/archive/refs/tags/v${pkgver}.tar.gz)
+md5sums=('a58bd957bd98e0f74340d4ab7cee0f48')
build() {
-cd $srcdir/$pkgname-$pkgver
-make
+ cd $srcdir/$pkgname
+ make
}
package() {
-cd $srcdir/$pkgname-$pkgver
-install -D -m755 ./bsod $pkgdir/usr/bin/bsod
+ cd $srcdir/$pkgname
+ install -D -m755 ./bsod $pkgdir/usr/bin/bsod
}