summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkshay Nair2020-05-17 18:06:17 +0530
committerAkshay Nair2020-05-17 18:06:17 +0530
commit619caf27fd753cfb4e9f660922c50c2dc21eef56 (patch)
tree56b8078940aca28d0070ada358d0b8c4816051eb
downloadaur-619caf27fd753cfb4e9f660922c50c2dc21eef56.tar.gz
Adds pkgbuild stuff
-rw-r--r--.SRCINFO17
-rw-r--r--.install40
-rw-r--r--PKGBUILD22
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27b14513f450
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bsp-layout
+ pkgdesc = Dynamic layout management for bspwm with tall, wide, even, tiled, monocle
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/phenax/bsp-layout
+ install = .install
+ arch = any
+ license = MIT
+ makedepends = bash
+ depends = bash
+ provides = bsp-layout
+ conflicts = bsp-layout
+ source = git+https://github.com/phenax/bsp-layout.git
+ md5sums = SKIP
+
+pkgname = bsp-layout
+
diff --git a/.install b/.install
new file mode 100644
index 000000000000..1d50061a39e3
--- /dev/null
+++ b/.install
@@ -0,0 +1,40 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+#post_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#post_upgrade() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+post_remove() {
+ local INSTALL_DIR=/usr/lib/bsp-layout;
+ local BINARY=/usr/local/bin/bsp-layout;
+
+ # Clean up
+ rm -rf $INSTALL_DIR;
+ rm -rf $BINARY;
+}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9acc685d99c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Akshay Nair <phenax5@gmail.com>
+pkgname=bsp-layout
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Dynamic layout management for bspwm with tall, wide, even, tiled, monocle"
+arch=('any')
+url="https://github.com/phenax/bsp-layout"
+license=('MIT')
+depends=('bash')
+makedepends=('bash')
+checkdepends=()
+optdepends=()
+provides=("$pkgname")
+conflicts=("$pkgname")
+install=".install"
+source=('git+https://github.com/phenax/bsp-layout.git')
+md5sums=('SKIP')
+
+package() {
+ cd "$pkgname";
+ sudo ./install.sh local;
+}