summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Ramos Rehermann2022-09-30 17:53:58 -0300
committerGustavo Ramos Rehermann2022-09-30 17:53:58 -0300
commit83a3e7b6d897b526c0e61239fee19197c2bc8b64 (patch)
tree05b544dc6020afac32c9ecd0cc8b20aba0a8605c
downloadaur-83a3e7b6d897b526c0e61239fee19197c2bc8b64.tar.gz
Initialize package PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD58
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..683233f41344
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = bspc-padman-git
+ pkgdesc = Quake 3 BSP-to-AAS compiler, WorldOfPadman version
+ pkgver = 1659723467.168.6417739
+ pkgrel = 1
+ url = https://github.com/PadWorld-Entertainment/bspc
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = ninja
+ provides = bspc
+ provides = bspc-padman
+ conflicts = bspc
+ conflicts = bspc-padman
+ source = git+https://github.com/PadWorld-Entertainment/bspc.git
+ md5sums = SKIP
+
+pkgname = bspc-padman-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..088f781994c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Gustavo Ramos Rehermann <rehermann6046@gmail.com>
+pkgname=bspc-padman-git
+_srcname=bspc
+pkgver=1659723467.168.6417739
+pkgrel=1
+pkgdesc="Quake 3 BSP-to-AAS compiler, WorldOfPadman version"
+arch=("x86_64")
+url="https://github.com/PadWorld-Entertainment/bspc"
+license=('GPL')
+groups=()
+depends=()
+makedepends=('git' 'cmake' 'ninja') # 'bzr', 'git', 'mercurial' or 'subversion'
+optdepends=()
+provides=("bspc" "bspc-padman")
+conflicts=("bspc" "bspc-padman")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/PadWorld-Entertainment/bspc.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_srcname"
+
+ # Use timestamp, because there are no tags or other sorts of version information,
+ # to inform AUR helpers' update processes.
+ printf "%s.%s.%s" "$(git show -s --format=%ct HEAD)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir"
+
+ cmake -B build -S "$_srcname" \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev \
+ -G Ninja
+
+ cmake --build build
+}
+package() {
+ # The below does not work, presumably because of the None target.
+ #DESTDIR="$pkgdir/" cmake --install build
+
+ # Also rename bspcwop to bspc.
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$srcdir/build/bspcwop" "$pkgdir/usr/bin/bspc"
+}