summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten de Boer2021-05-25 18:19:52 +0200
committerMaarten de Boer2021-05-25 18:19:52 +0200
commita71a86758d1caea6d171d8d4f4cbef4da146ee26 (patch)
tree9605fc4101944f7efefcb0a4f35ed61fd0f7de00
parentb4ec1b7ba4273227e453e01ce31c915a5998779b (diff)
downloadaur-a71a86758d1caea6d171d8d4f4cbef4da146ee26.tar.gz
Use correct commit for 0.9.10
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD14
3 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9555d570456..17ef11dbe1f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bspwm-rounded-corners
pkgdesc = Tiling window manager based on binary space partitioning
pkgver = 0.9.10
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/phuhl/bspwm-rounded
install = bspwm-rounded-corners.install
arch = x86_64
@@ -14,8 +14,8 @@ pkgbase = bspwm-rounded-corners
optdepends = xdo: for the example panel
conflicts = bspwm
conflicts = bspwm-git
- source = https://github.com/phuhl/bspwm-rounded/archive/refs/tags/0.9.10.tar.gz
- sha256sums = da72da3ab55af43f6cecef94d8545d9f6ded5c2840475971b0a2d968fa281c3a
+ source = bspwm-rounded-corners-0.9.10.tar.gz::https://github.com/phuhl/bspwm-rounded/archive/98e96427aa4af1d7b0c2f0e45a5ef8bbd6407a0b.tar.gz
+ sha256sums = 76b8de33faf54633f315f246b48328cd9011ec449569e3e9ee7186b1b1834bb4
pkgname = bspwm-rounded-corners
diff --git a/.gitignore b/.gitignore
index 2242655958bd..66a6cf4a7f5d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
/src
+/pkg
/*.tar.gz
-/*.zst \ No newline at end of file
+/*.zst
diff --git a/PKGBUILD b/PKGBUILD
index 9e49b03f64ae..aa3a246a351a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maarten de Boer <maarten@cloudstek.nl>
pkgname=bspwm-rounded-corners
pkgver=0.9.10
-pkgrel=1
+pkgrel=2
pkgdesc="Tiling window manager based on binary space partitioning"
arch=(x86_64)
url="https://github.com/phuhl/bspwm-rounded"
@@ -11,19 +11,23 @@ makedepends=(git)
optdepends=('sxhkd: to define keyboard and pointer bindings'
'xdo: for the example panel')
conflicts=(bspwm bspwm-git)
-source=("https://github.com/phuhl/bspwm-rounded/archive/refs/tags/$pkgver.tar.gz")
install=$pkgname.install
-sha256sums=('da72da3ab55af43f6cecef94d8545d9f6ded5c2840475971b0a2d968fa281c3a')
+
+_git_ref=98e96427aa4af1d7b0c2f0e45a5ef8bbd6407a0b
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/phuhl/bspwm-rounded/archive/${_git_ref}.tar.gz")
+
+sha256sums=('76b8de33faf54633f315f246b48328cd9011ec449569e3e9ee7186b1b1834bb4')
build() {
- cd "$srcdir/bspwm-rounded-$pkgver"
+ cd "$srcdir/bspwm-rounded-${_git_ref}"
CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
make PREFIX=/usr
}
package() {
- cd "$srcdir/bspwm-rounded-$pkgver"
+ cd "$srcdir/bspwm-rounded-${_git_ref}"
make PREFIX=/usr DESTDIR="$pkgdir" install