summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryarob2022-10-09 14:56:13 +0200
committeryarob2022-10-09 14:56:13 +0200
commit330da13cf6e94610d24568d4a305c2309a607b4c (patch)
tree5049204be3ccad8aef493afe853b821a4ede1233
downloadaur-330da13cf6e94610d24568d4a305c2309a607b4c.tar.gz
Init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9a259f45d67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = bspwm
+ pkgdesc = minimal window manager
+ pkgver = 0.9.10
+ pkgrel = 1
+ url = https://github.com/yarob-0/bspwm
+ arch = x86_64
+ license = BSD
+ makedepends = make
+ makedepends = git
+ depends = xcb-util
+ depends = xcb-util-wm
+ depends = xcb-util-keysyms
+ optdepends = sxhkd: to define keyboard and pointer bindings [installed]
+ optdepends = xdo: for the example panel
+ provides = bspwm
+ provides = bspc
+ source = bspwm::git+https://github.com/yarob-0/bspwm.git
+ md5sums = SKIP
+
+pkgname = bspwm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a5cdba37cb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=bspwm
+pkgver=0.9.10
+pkgrel=1
+pkgdesc="minimal window manager"
+arch=("x86_64")
+url="https://github.com/yarob-0/bspwm"
+license=('BSD')
+depends=("xcb-util" "xcb-util-wm" "xcb-util-keysyms")
+makedepends=("make" "git")
+optdepends=("sxhkd: to define keyboard and pointer bindings [installed]"
+ "xdo: for the example panel")
+provides=("bspwm" "bspc")
+source=("bspwm"::"git+https://github.com/yarob-0/bspwm.git")
+md5sums=("SKIP")
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}