summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Rabert2024-03-03 16:53:34 -0500
committerAndrew Rabert2024-03-03 16:53:34 -0500
commitf612948a048010b18a754eb5f030e373a7e9a2ff (patch)
tree089434ee5c77e47bf5da0eb06281e781cad42240
downloadaur-f612948a048010b18a754eb5f030e373a7e9a2ff.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD41
-rw-r--r--bstone.install4
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75b1b1fc572b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = bstone-git
+ pkgdesc = Unofficial source port for Blake Stone series (Aliens Of Gold and Planet Strike).
+ pkgver = r2302.e2e780db
+ pkgrel = 1
+ url = https://github.com/bibendovsky/bstone
+ install = bstone.install
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = GPL2
+ makedepends = cmake
+ depends = sdl2
+ provides = bstone
+ source = git+https://github.com/bibendovsky/bstone.git
+ sha256sums = SKIP
+
+pkgname = bstone-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ae6332faa901
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!/.SRCINFO
+!/.gitignore
+!/PKGBUILD
+!/bstone.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b69c58b06eaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Andrew Rabert <ar@nullsum.net>
+
+pkgname=bstone-git
+pkgver=r2302.e2e780db
+pkgrel=1
+pkgdesc="Unofficial source port for Blake Stone series (Aliens Of Gold and Planet Strike)."
+arch=('i686' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/bibendovsky/bstone"
+license=('GPL2')
+depends=("sdl2")
+makedepends=('cmake')
+provides=('bstone')
+install="bstone.install"
+source=("git+https://github.com/bibendovsky/bstone.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd bstone
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/bstone"
+ mkdir -p build && cd build
+ cmake -B. -H.. \
+ -DCMAKE_INSTALL_PREFIX='/usr/bin' \
+ -DCMAKE_C_COMPILER=gcc \
+ -DCMAKE_CXX_COMPILER=g++ \
+ -DCMAKE_BUILD_TYPE='RelWithDebInfo'
+ make
+}
+
+package() {
+ cd "${srcdir}/bstone/build"
+ make DESTDIR="${pkgdir}" install
+ install -dm655 "${pkgdir}/usr/share/doc/bstone"
+ rm -f "${pkgdir}"/usr/bin/*license.txt
+ mv "${pkgdir}"/usr/bin/*.txt "${pkgdir}/usr/share/doc/bstone"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/bstone.install b/bstone.install
new file mode 100644
index 000000000000..7baa22c38038
--- /dev/null
+++ b/bstone.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo ">>> Run game with 'bstone --data_dir <path_to_game_data>"
+ echo ">>> See https://github.com/bibendovsky/bstone#11---command-line-options for list of available command line switches."
+}