summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio Conde Gómez2015-06-08 12:20:04 +0200
committerSergio Conde Gómez2015-06-08 12:20:04 +0200
commit390d989ac4e709ad569b3e30faf2e4fa4f053621 (patch)
tree30f274e47954aebb30bfec6fc3187ec716dcdedf
downloadaur-390d989ac4e709ad569b3e30faf2e4fa4f053621.tar.gz
Import 2.1+-2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77372898f7e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bsvc_etsiinf-upm
+ pkgdesc = Motorola MC68000 simulator precompiled by the Department of Architecture and Technology Information Systems (DATSI) of the School of Computer Engineers (ETSIInf) at the Technical University of Madrid (UPM).
+ pkgver = 2.1+
+ pkgrel = 2
+ url = http://www.datsi.fi.upm.es/docencia/Arquitectura_09/Proyecto_E_S/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = tk
+ depends = xterm
+ source = http://www.datsi.fi.upm.es/docencia/Arquitectura_09/Proyecto_E_S/bsvc-2.1+_Estatica.tar.gz
+ sha256sums = 0e6f20b2eaa6cc64ae84cae480f4dc5db7dd797a704e7ce2f99e6c75798523a2
+
+pkgname = bsvc_etsiinf-upm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b587ece1d2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sergio Conde <skgsergio@gmail.com>
+pkgname=bsvc_etsiinf-upm
+pkgver=2.1+
+pkgrel=2
+pkgdesc="Motorola MC68000 simulator precompiled by the Department of Architecture and Technology Information Systems (DATSI) of the School of Computer Engineers (ETSIInf) at the Technical University of Madrid (UPM)."
+arch=('i686' 'x86_64')
+url='http://www.datsi.fi.upm.es/docencia/Arquitectura_09/Proyecto_E_S/'
+license=('custom')
+depends=('tk' 'xterm')
+source=(
+ 'http://www.datsi.fi.upm.es/docencia/Arquitectura_09/Proyecto_E_S/bsvc-2.1+_Estatica.tar.gz'
+)
+sha256sums=(
+ '0e6f20b2eaa6cc64ae84cae480f4dc5db7dd797a704e7ce2f99e6c75798523a2'
+)
+
+package() {
+ # Copy files to pkgdir
+ cp -R "${srcdir}"/usr "${pkgdir}"/usr
+
+ # Create links in /usr/local/bin/ for the executable binaries found in /usr/local/bsvc/bin/
+ mkdir "${pkgdir}"/usr/local/bin
+ for file in "${pkgdir}"/usr/local/bsvc/bin/*; do
+ if [ -f ${file} ] && [ -x ${file} ]; then
+ ln -s ../bsvc/bin/"$(basename ${file})" "${pkgdir}"/usr/local/bin/"$(basename ${file})"
+ fi
+ done
+
+ # Reset UI fonts and colors
+ echo -n > "${pkgdir}"/usr/local/bsvc/bin/UI/bsvc.ad
+
+ # Install license
+ install -Dm644 "${pkgdir}"/usr/local/bsvc/License.doc "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}