summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEike Baran2015-08-12 00:44:01 +0200
committerEike Baran2015-08-12 00:44:01 +0200
commitc8646abc35abdde2bb1b6b41431207fa1ed18073 (patch)
tree29ad50b32f1508913cb5db43fe59d2e0948851ff
downloadaur-c8646abc35abdde2bb1b6b41431207fa1ed18073.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd2f49e72859
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bsync-git
+ pkgdesc = Bidirectional Synchronization using Rsync
+ pkgver = 84.4598ba9
+ pkgrel = 1
+ url = https://github.com/dooblem/bsync
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python>=3
+ source = git://github.com/dooblem/bsync
+ md5sums = SKIP
+
+pkgname = bsync-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf898b573dde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Eike Baran <eike.baran at uni-oldenburg.de>
+
+pkgname=bsync-git
+pkgver=84.4598ba9
+pkgrel=1
+pkgdesc="Bidirectional Synchronization using Rsync"
+url="https://github.com/dooblem/bsync"
+license=('GPL')
+depends=('python>=3')
+makedepends=('git')
+arch=('any')
+source=("git://github.com/dooblem/bsync")
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+# see also https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
+pkgver() {
+ cd "$srcdir/bsync"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ install -D "$srcdir/bsync/bsync" "$pkgdir/usr/bin/bsync"
+}