summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYujia Qiao2021-10-31 22:03:02 +0800
committerYujia Qiao2021-10-31 22:05:44 +0800
commit72a047642449c670ec79616ff6888de87b487220 (patch)
tree2aa18d43f4a9bca6907869d44b3aef97920d01d4
downloadaur-72a047642449c670ec79616ff6888de87b487220.tar.gz
addpkg: btcdeb
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD32
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b24d61c1a3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = btcdeb
+ pkgdesc = Bitcoin Script Debugger
+ pkgver = 0.3.20
+ pkgrel = 1
+ url = https://github.com/bitcoin-core/btcdeb
+ arch = x86_64
+ license = MIT
+ makedepends = automake
+ source = https://github.com/bitcoin-core/btcdeb/archive/refs/tags/0.3.20.tar.gz
+ md5sums = b2724041b93dfe24e434b6bd8038e9dd
+
+pkgname = btcdeb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e3cb4105c53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Yujia Qiao <rapiz3142@gmail.com>
+pkgname=btcdeb
+pkgver=0.3.20
+pkgrel=1
+pkgdesc="Bitcoin Script Debugger"
+arch=(x86_64)
+url="https://github.com/bitcoin-core/btcdeb"
+license=('MIT')
+makedepends=(automake)
+source=("https://github.com/bitcoin-core/btcdeb/archive/refs/tags/$pkgver.tar.gz")
+md5sums=('b2724041b93dfe24e434b6bd8038e9dd')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}