summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Panteleev2023-02-25 20:06:09 +0000
committerVladimir Panteleev2023-02-25 20:06:09 +0000
commit00bf7cd17dad7a380f52a2b6953617575ba3daa1 (patch)
tree82efeecff9c850bfceea201d6d63871bf7794f24
parentcd383ac5abc14a78ed3bfb1264d16ac5aaf2d8b7 (diff)
downloadaur-00bf7cd17dad7a380f52a2b6953617575ba3daa1.tar.gz
Some support for aarch64
This is still contingent on Arch Linux ARM packaging dtools (as in Arch Linux).
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be5e87d79d74..fea3176fbd0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,10 +3,11 @@ pkgbase = btdu
pkgver = 0.5.0
pkgrel = 1
url = https://github.com/CyberShadow/btdu
+ arch = aarch64
arch = i686
arch = x86_64
license = GPL2
- makedepends = d-compiler
+ makedepends = d-compiler>=2.97.0
makedepends = dub
makedepends = dtools
depends = ncurses
diff --git a/PKGBUILD b/PKGBUILD
index 83633c178401..937ce25bb273 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,11 +26,12 @@ pkgname=btdu
pkgver=0.5.0
pkgrel=1
pkgdesc='sampling disk usage profiler for btrfs'
-arch=('i686' 'x86_64')
+arch=('aarch64' 'i686' 'x86_64')
url='https://github.com/CyberShadow/btdu'
license=('GPL2')
depends=('ncurses' 'd-runtime')
-makedepends=('d-compiler' 'dub' 'dtools')
+_d_compiler_spec='d-compiler>=2.97.0'
+makedepends=("$_d_compiler_spec" 'dub' 'dtools')
# These should match dub.selections.json from the btdu repository:
_d_ae_ver=0.0.3228
@@ -62,8 +63,13 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- HOME="${srcdir}/_dub" dub --skip-registry=all build -b release --rdmd || # --rdmd creates smaller binaries
- HOME="${srcdir}/_dub" dub --skip-registry=all build -b release # retry without --rdmd - https://github.com/dlang/dub/pull/2033
+
+ # Ensure Dub doesn't try to use GDC
+ local d_compiler
+ d_compiler=$(pacman -Qq "$_d_compiler_spec")
+
+ HOME="${srcdir}/_dub" dub --skip-registry=all build --compiler="$d_compiler" -b release --rdmd || # --rdmd creates smaller binaries
+ HOME="${srcdir}/_dub" dub --skip-registry=all build --compiler="$d_compiler" -b release # retry without --rdmd - https://github.com/dlang/dub/pull/2033
}
package() {