summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2017-07-26 09:39:44 -0400
committerSolomon Choina2017-07-26 09:39:44 -0400
commit853d15ecd1bc37d1da5f047ad1a42d7482254577 (patch)
treecc851de1e983bbde855d22827411f840829063af
parent614c2318d95b731d268055e1f1681311f869f6e6 (diff)
downloadaur-853d15ecd1bc37d1da5f047ad1a42d7482254577.tar.gz
upstream pushed fixes to make it work
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD25
2 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b779535193fc..28b16e62c0ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jul 24 14:32:34 UTC 2017
+# Wed Jul 26 13:39:22 UTC 2017
pkgbase = bterm-git
pkgdesc = cross-platform terminal emulator
- pkgver = v1.0.0.r10.8b9d9f2
- pkgrel = 3
+ pkgver = v1.0.0.r13.95e17d6
+ pkgrel = 1
url = https://github.com/bleenco/bterm
arch = x86_64
license = MIT
@@ -13,6 +13,7 @@ pkgbase = bterm-git
makedepends = dpkg
makedepends = unp
depends = nodejs
+ conflicts = bterm
source = bterm-git::git+https://github.com/bleenco/bterm.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 637e32f81d51..1a3cfc4917eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com>
pkgname=bterm-git
_pkgname=bterm
-pkgver=v1.0.0.r10.8b9d9f2
-pkgrel=3
+pkgver=v1.0.0.r13.95e17d6
+pkgrel=1
pkgdesc="cross-platform terminal emulator"
arch=('x86_64')
url="https://github.com/bleenco/bterm"
license=('MIT')
+conflicts=('bterm')
depends=('nodejs')
#dpkg is not actually needed, it's just to avoid a build failure
makedepends=('git' 'npm' "libicns" "dpkg" "unp")
@@ -31,12 +32,18 @@ package() {
cd "$srcdir/${pkgname}"
unp dist/bterm_1.0.0_amd64.deb
unp data.tar.xz
+ #appdir=/usr/lib/$_pkgname
+ #install -d "$pkgdir/usr/bin/"
+ #local _icon_dir="usr/share/icons/hicolor"
+ #install -d "${pkgdir}"${appdir}
+ #cp -r dist/bterm-linux-x64/* "${pkgdir}"${appdir}
mv usr "${pkgdir}"
- local _icon_dir="usr/share/icons/hicolor"
- for size in 32 512; do
- install -Dm644 \
- assets/icon_${size}x${size}.png \
- "${pkgdir}"/$_icon_dir/${size}x${size}/apps/${pkgname}.png
- done
-install -Dm644 assets/icon.svg $pkgdir/$_icon_dir/scalable/apps/$pkgname.svg
+ # local _icon_dir="usr/share/icons/hicolor"
+ #for size in 32 512; do
+ # install -Dm644 \
+ # assets/icon_${size}x${size}.png \
+ # "${pkgdir}"/$_icon_dir/${size}x${size}/apps/${pkgname}.png
+ # done
+#install -Dm644 assets/icon.svg $pkgdir/$_icon_dir/scalable/apps/$pkgname.svg
+#ln -s /usr/lib/bterm/bterm $pkgdir/usr/bin/$_pkgname
}