summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleg Plakhotniuk2015-12-03 14:09:41 -0600
committerOleg Plakhotniuk2015-12-03 14:09:41 -0600
commitaffd79179494f86d3dbf337cd5ff46236bef1226 (patch)
tree61bf5044894674a6edb461190a0265257449089c
downloadaur-btogre.tar.gz
Initial version based on AUR3 package btogre-git.
-rw-r--r--.SRCINFO25
-rw-r--r--BtOgre.cpp.patch5
-rw-r--r--PKGBUILD39
-rw-r--r--cmake-targets.patch30
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6ae1361b4ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = btogre
+ pkgdesc = A thin Bullet-Ogre connection.
+ pkgver = 6266297
+ pkgrel = 1
+ url = http://www.ogre3d.org/forums/viewtopic.php?f=5&t=46856
+ arch = i686
+ arch = x86_64
+ license = zlib
+ makedepends = git
+ makedepends = cmake
+ makedepends = boost
+ depends = bullet
+ depends = ogre
+ source = git://github.com/nikki93/btogre.git#commit=6266297
+ source = cmake-targets.patch
+ source = BtOgre.cpp.patch
+ md5sums = SKIP
+ md5sums = 04de7ba58a645b96739e50092ae7a067
+ md5sums = b46331fc6ef646bc37426f3fe62f04c1
+ sha1sums = SKIP
+ sha1sums = b705573e40bf33f3ee76f08ebead2b67f577fa4c
+ sha1sums = 23c30bcff53457d4f0c76ce757830bb46d0afbbe
+
+pkgname = btogre
+
diff --git a/BtOgre.cpp.patch b/BtOgre.cpp.patch
new file mode 100644
index 000000000000..aea5ba604a41
--- /dev/null
+++ b/BtOgre.cpp.patch
@@ -0,0 +1,5 @@
+353c353,354
+< trimesh->addTriangle(vertexPos[0], vertexPos[1], vertexPos[2]);
+---
+> // Create continuous mesh.
+> trimesh->addTriangle(vertexPos[0], vertexPos[1], vertexPos[2], true);
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99a48a4d4805
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Alexander 'z33ky' Hirsch <1zeeky@gmail.com>
+# Maintainer: Oleg Plakhotniuk <olegus8@gmail.com>
+
+pkgname=btogre
+pkgver=6266297
+pkgrel=1
+pkgdesc='A thin Bullet-Ogre connection.'
+arch=('i686' 'x86_64')
+url='http://www.ogre3d.org/forums/viewtopic.php?f=5&t=46856'
+license=('zlib')
+depends=('bullet' 'ogre')
+makedepends=('git' 'cmake' 'boost')
+source=("git://github.com/nikki93/${pkgname}.git#commit=${pkgver}" 'cmake-targets.patch' 'BtOgre.cpp.patch')
+md5sums=('SKIP'
+ '04de7ba58a645b96739e50092ae7a067'
+ 'b46331fc6ef646bc37426f3fe62f04c1')
+sha1sums=('SKIP'
+ 'b705573e40bf33f3ee76f08ebead2b67f577fa4c'
+ '23c30bcff53457d4f0c76ce757830bb46d0afbbe')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+
+ patch -Np1 -i "${srcdir}/cmake-targets.patch"
+ patch "${srcdir}/${pkgname}/BtOgre.cpp" "${srcdir}/BtOgre.cpp.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/cmake-targets.patch b/cmake-targets.patch
new file mode 100644
index 000000000000..656ebebad95c
--- /dev/null
+++ b/cmake-targets.patch
@@ -0,0 +1,30 @@
+commit 05cdf41dd6937fb02031727c8a5735aca70be439
+Author: Alexander Hirsch <1zeeky@gmail.com>
+Date: Thu Feb 21 04:00:41 2013 +0100
+
+ add cmake install targets
+
+diff --git a/BtOgreConfig.cmake b/BtOgreConfig.cmake
+new file mode 100644
+index 0000000..d29444d
+--- /dev/null
++++ b/BtOgreConfig.cmake
+@@ -0,0 +1,2 @@
++find_path(BtOgre_INCLUDE_DIR BtOgreGP.h HINTS "/usr/include/BtOgre" "/usr/include")
++find_library(BtOgre_LIBRARY NAMES BtOgre libBtOgre HINTS "/usr/lib")
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4fe3d14..6d44be4 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -15,3 +15,11 @@ include_directories(
+
+ add_library(BtOgre STATIC BtOgre.cpp)
+ target_link_libraries(BtOgre ${BULLET_LIBRARIES} ${OGRE_LIBRARIES})
++
++file(GLOB BtOgre_HEADERS "${PROJECT_SOURCE_DIR}/include/*.h")
++set_target_properties(BtOgre PROPERTIES PUBLIC_HEADER "${BtOgre_HEADERS}")
++
++install(TARGETS BtOgre
++ PUBLIC_HEADER DESTINATION include/BtOgre
++ ARCHIVE DESTINATION lib)
++install(FILES BtOgreConfig.cmake DESTINATION lib/cmake/BtOgre)