summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladislav Nepogodin2023-06-04 02:18:50 +0400
committerVladislav Nepogodin2023-06-04 02:18:50 +0400
commitfaac9b38bf342f0a3b20bf3fbab5d16c4b8817bc (patch)
treee3423147e99ac468fb1dc57de67d5e96bc83fa78
parente87a7f9d23cc8901404bc49a9c47818ac19c0ea9 (diff)
downloadaur-faac9b38bf342f0a3b20bf3fbab5d16c4b8817bc.tar.gz
🚧 fix git submodule
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d0b16aa66be..e335c7c09837 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = btop-git
pkgdesc = A monitor of resources
- pkgver = 1.0.18.r292.a0ee404
+ pkgver = 1.2.13.r698.e269046
pkgrel = 1
url = https://github.com/aristocratos/btop
arch = any
@@ -12,6 +12,8 @@ pkgbase = btop-git
conflicts = btop
options = !strip
source = btop-git::git+https://github.com/aristocratos/btop.git
+ source = git+https://github.com/fmtlib/fmt.git
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = btop-git
diff --git a/PKGBUILD b/PKGBUILD
index eb2a8a2c0465..fa78d467eb4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
# Maintainer: Vladislav Nepogodin <nepogodin.vlad@gmail.com>
pkgname=btop-git
-pkgver=1.0.18.r292.a0ee404
+pkgver=1.2.13.r698.e269046
pkgrel=1
pkgdesc="A monitor of resources"
arch=(any)
url="https://github.com/aristocratos/btop"
license=('Apache-2.0')
makedepends=('gcc' 'make' 'git')
-source=("${pkgname}::git+https://github.com/aristocratos/btop.git")
-sha512sums=('SKIP')
+source=("${pkgname}::git+https://github.com/aristocratos/btop.git"
+ "git+https://github.com/fmtlib/fmt.git")
+sha512sums=('SKIP'
+ 'SKIP')
provides=('btop')
conflicts=('btop')
options=(!strip)
@@ -21,6 +23,14 @@ pkgver() {
printf "${_pkgver}.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/${pkgname}"
+
+ git submodule init
+ git config submodule."lib/fmt".url "${srcdir}/fmt"
+ git -c protocol.file.allow=always submodule update
+}
+
build() {
cd "${pkgname}"