summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-01-17 18:36:42 +0100
committerwillemw122023-01-17 18:36:42 +0100
commitcf084deb479077499cdbe8f92d71936801a402ed (patch)
tree9a28a7461f4ed0c33360bff865473a086c54c840
parent9f2b9506cef6a5344e4496650c8c5ad65454a48c (diff)
downloadaur-cf084deb479077499cdbe8f92d71936801a402ed.tar.gz
Fix source name. Remove BINDIR="/usr/bin" from make install, ...
Change description, optdepends description.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13de16c00018..70e72fd7b384 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,16 +2,16 @@ pkgbase = btrbk
pkgdesc = Backup tool for btrfs subvolumes, taking advantage of btrfs specific capabilities to create atomic snapshots and transfer them incrementally to your backup locations
pkgver = 0.32.5
pkgrel = 1
- url = https://digint.ch/btrbk
+ url = https://digint.ch/btrbk/
arch = any
license = GPL3
makedepends = asciidoctor
- depends = perl
depends = btrfs-progs
- optdepends = openssh: remote backup support,
- optdepends = mbuffer: --progress support and add buffering to send-stream
- optdepends = sudo: support for the btrfs-progs-sudo backend
- source = https://digint.ch/download/btrbk/releases/btrbk-0.32.5.tar.xz
- b2sums = 036a2b5c31a308dbc1efc7a27211f89dfc07bcfcead49deb68a2e8313aec9539483ef3a91481f4ebaa9d2b4817b202ced1945a30ed7fc9b51f1336878b2f17d7
+ depends = perl
+ optdepends = mbuffer: send/receive buffering and rate limiting, progress bars
+ optdepends = openssh: transfer backups from/to remote locations,
+ optdepends = sudo: btrfs-progs-sudo backend
+ source = btrbk-0.32.5.tar.gz::https://digint.ch/download/btrbk/releases/btrbk-0.32.5.tar.xz
+ sha256sums = f1fe4091680216d78c7903d82a7f8ff95e98a5beb1d1ffdb2ba5293a8bc39fb4
pkgname = btrbk
diff --git a/PKGBUILD b/PKGBUILD
index 2ca65b752d6c..3cac08fb68e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
-# Maintainer: Michael Duell < mail at akurei dot me >
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Michael Duell < mail at akurei dot me >
# Contributor: Myles English <myles at rockhead dot biz>
+
pkgname=btrbk
pkgver=0.32.5
pkgrel=1
pkgdesc="Backup tool for btrfs subvolumes, taking advantage of btrfs specific capabilities to create atomic snapshots and transfer them incrementally to your backup locations"
-url="https://digint.ch/btrbk"
arch=('any')
+url="https://digint.ch/btrbk/"
license=('GPL3')
-depends=('perl' 'btrfs-progs')
+depends=('btrfs-progs' 'perl')
makedepends=('asciidoctor')
-optdepends=('openssh: remote backup support',
- 'mbuffer: --progress support and add buffering to send-stream'
- 'sudo: support for the btrfs-progs-sudo backend')
-source=("https://digint.ch/download/btrbk/releases/${pkgname}-${pkgver}.tar.xz")
+optdepends=('mbuffer: send/receive buffering and rate limiting, progress bars'
+ 'openssh: transfer backups from/to remote locations',
+ 'sudo: btrfs-progs-sudo backend')
+source=("$pkgname-$pkgver.tar.gz::https://digint.ch/download/btrbk/releases/$pkgname-$pkgver.tar.xz")
+sha256sums=('f1fe4091680216d78c7903d82a7f8ff95e98a5beb1d1ffdb2ba5293a8bc39fb4')
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" BINDIR="/usr/bin" install
+ make -C $pkgname-$pkgver DESTDIR="$pkgdir/" install
}
-b2sums=('036a2b5c31a308dbc1efc7a27211f89dfc07bcfcead49deb68a2e8313aec9539483ef3a91481f4ebaa9d2b4817b202ced1945a30ed7fc9b51f1336878b2f17d7')