summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel J. Campos2015-06-09 01:25:29 +0000
committerDaniel J. Campos2015-06-09 01:25:29 +0000
commitdec096701e7af5990b9307d7b06f1ab9508fe009 (patch)
tree7826c261b3f84f1e2b46413d84208e806399fbd2
downloadaur-dec096701e7af5990b9307d7b06f1ab9508fe009.tar.gz
Migration to AUR4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a619aa0cb543
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = btrbk-git
+ pkgdesc = A backup tool for btrfs subvolumes, taking advantage of btrfs specific capabilities to create atomic snapshots and transfer them incrementally to your backup locations.
+ pkgver = 20150609
+ pkgrel = 1
+ url = http://digint.ch/btrbk
+ arch = any
+ license = GPL3
+ depends = perl
+ depends = perl-date-calc
+ depends = btrfs-progs
+ optdepends = openssh: remote backup support
+ conflicts = btrbk
+ source = git+https://github.com/digint/btrbk.git
+ sha256sums = SKIP
+
+pkgname = btrbk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f175dd8a8a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Daniel J. Campos <dcampos2015 at my dot fit dot edu>
+pkgname=btrbk-git
+pkgver=20150609
+pkgrel=1
+pkgdesc="A backup tool for btrfs subvolumes, taking advantage of btrfs specific capabilities to create atomic snapshots and transfer them incrementally to your backup locations."
+url="http://digint.ch/btrbk"
+arch=('any')
+license=('GPL3')
+conflicts=('btrbk')
+depends=('perl' 'perl-date-calc' 'btrfs-progs')
+optdepends=('openssh: remote backup support')
+source=("git+https://github.com/digint/btrbk.git")
+sha256sums=('SKIP')
+package() {
+ cd "${srcdir}/btrbk"
+ sed -i 's/sbin/bin/g' contrib/systemd/btrbk.service
+ make DESTDIR="${pkgdir}" BINDIR="/usr/bin" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/btrbk/COPYING"
+}
+
+