summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVVL2018-08-30 10:49:06 +0300
committerVVL2018-08-30 10:49:06 +0300
commit41645b0fd53ac2d494f16b51cf58d714eda16319 (patch)
treef35ae050307106ba6f381299ec641e860539d04e
parent4026e53bb80cdbbff569110c0bf850532ea02808 (diff)
downloadaur-41645b0fd53ac2d494f16b51cf58d714eda16319.tar.gz
update to 1.0.0
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD10
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a81c9f2c692..4bafc5dc26bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Wed Aug 29 22:16:51 UTC 2018
+# Thu Aug 30 07:48:39 UTC 2018
pkgbase = btrfs-autosnap
pkgdesc = Pacman hook which makes btrfs root snapshot before any action.
- pkgver = 0.9.1
- pkgrel = 2
+ pkgver = 1.0.0
+ pkgrel = 1
url = https://github.com/vvl-rulez/btrfs-autosnap
arch = any
license = MIT
depends = btrfs-progs
depends = util-linux
- source = https://github.com/vvl-rulez/btrfs-autosnap/archive/v0.9.1.tar.gz
- sha256sums = 7f77e0040461e3bfe1dc8a3bf7abc2e7d3c3dc68d048e664406fc5e524af4ec4
+ depends = coreutils
+ backup = etc/btrfs-autosnap.conf
+ source = https://github.com/vvl-rulez/btrfs-autosnap/archive/v1.0.0.tar.gz
+ sha256sums = e49e7905f582dbc46eb2b11d9d99d68c90dc2d905c157a4f7ee4ad9480caa7e7
pkgname = btrfs-autosnap
diff --git a/PKGBUILD b/PKGBUILD
index ef1608a07cad..1954ae0e5f13 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,20 @@
# Contributor: VVL <me@ivvl.ru>
pkgname=btrfs-autosnap
-pkgver=0.9.1
-pkgrel=2
+pkgver=1.0.0
+pkgrel=1
pkgdesc="Pacman hook which makes btrfs root snapshot before any action."
arch=(any)
url="https://github.com/vvl-rulez/btrfs-autosnap"
license=('MIT')
source=("https://github.com/vvl-rulez/btrfs-autosnap/archive/v$pkgver.tar.gz")
-depends=('btrfs-progs' 'util-linux')
-sha256sums=('7f77e0040461e3bfe1dc8a3bf7abc2e7d3c3dc68d048e664406fc5e524af4ec4')
+depends=('btrfs-progs' 'util-linux' 'coreutils')
+sha256sums=('e49e7905f582dbc46eb2b11d9d99d68c90dc2d905c157a4f7ee4ad9480caa7e7')
+backup=('etc/btrfs-autosnap.conf')
package() {
cd "$pkgname-$pkgver"
install -Dm644 01-btrfs-autosnap.hook "${pkgdir}/usr/share/libalpm/hooks/01-btrfs-autosnap.hook"
+ install -Dm644 btrfs-autosnap.conf "${pkgdir}/etc/btrfs-autosnap.conf"
install -Dm755 btrfs-autosnap.sh "$pkgdir/usr/bin/btrfs-autosnap"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}