summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2014-05-08 17:10:12 -0600
committerBrian Bidulock2015-06-10 05:12:11 -0600
commit30d14d0f4a25b367d4e8650fbde862743b0eccc7 (patch)
tree85827ac4b3101c552d0cbe19fb6f3a3bb52a0dc8
parent0725a5b32e0d1bf08f40636c8ac326581372a3fe (diff)
downloadaur-30d14d0f4a25b367d4e8650fbde862743b0eccc7.tar.gz
version 2.1-3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD30
-rw-r--r--btscanner.changelog5
-rw-r--r--btscanner.patch78
4 files changed, 45 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59137319dc8c..de3029b12bfa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = btscanner
pkgdesc = Bluetooth device scanner.
pkgver = 2.1
- pkgrel = 4
+ pkgrel = 3
url = http://www.pentest.co.uk
changelog = btscanner.changelog
arch = i686
arch = x86_64
license = GPL
depends = bluez-libs
+ depends = bluez-utils
depends = libxml2
+ depends = ncurses
source = http://www.pentest.co.uk/src/btscanner-2.1.tar.bz2
source = btscanner.patch
md5sums = 587ec5847647d432eac1704b260af020
- md5sums = c1e3d85b9a01f941a111ccf747389def
+ md5sums = 481f2f5b49ba83b8ab8155983c911db9
pkgname = btscanner
diff --git a/PKGBUILD b/PKGBUILD
index 58649edb7ede..e5dd5b2d6916 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,27 @@
pkgname=btscanner
pkgver=2.1
-pkgrel=4
+pkgrel=3
pkgdesc="Bluetooth device scanner."
url="http://www.pentest.co.uk"
-depends=('bluez-libs' 'libxml2')
+depends=('bluez-libs' 'bluez-utils' 'libxml2' 'ncurses')
arch=(i686 x86_64)
license=('GPL')
-changelog=$pkgname.changelog
+changelog="btscanner.changelog"
source=(http://www.pentest.co.uk/src/$pkgname-$pkgver.tar.bz2
- $pkgname.patch)
+ btscanner.patch)
md5sums=('587ec5847647d432eac1704b260af020'
- '0b552988bffa2a843e2c52eb5f3a2f7c')
-
-prepare() {
- cd $pkgname-$pkgver
- patch -Np1 -b -z .orig -i ../$pkgname.patch
- mv configure.in configure.ac
- autoreconf -fiv
-}
-
+ '481f2f5b49ba83b8ab8155983c911db9')
build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr --sysconf=/etc/btscanner --datadir=/usr/share/btscanner
- make V=0
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < ../btscanner.patch
+ ./configure --prefix=/usr --sysconf=/etc/btscanner --datadir=/usr/share/btscanner || return 1
+ make
}
-
package() {
- cd $pkgname-$pkgver
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="${pkgdir}" install
# this is the only documentation
install -Dm644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
install -Dm644 USAGE "${pkgdir}/usr/share/doc/${pkgname}/USAGE"
}
-md5sums=('587ec5847647d432eac1704b260af020'
- 'c1e3d85b9a01f941a111ccf747389def')
diff --git a/btscanner.changelog b/btscanner.changelog
index a1731585414b..d06a5a2ca8c5 100644
--- a/btscanner.changelog
+++ b/btscanner.changelog
@@ -1,8 +1,3 @@
-2014-08-01 Brian Bidulock <bidulock@openss7.org>
-
- * 2.1-4:
- corrected buffer overflow
-
2013-04-11 Brian Bidulock <bidulock@openss7.org>
* 2.1-3 :
diff --git a/btscanner.patch b/btscanner.patch
index 71a8efeac5ec..1b349efdebe5 100644
--- a/btscanner.patch
+++ b/btscanner.patch
@@ -1,9 +1,24 @@
-diff -up btscanner-2.1/configure.in.orig btscanner-2.1/configure.in
---- btscanner-2.1/configure.in.orig 2005-11-21 06:56:56.000000000 -0700
-+++ btscanner-2.1/configure.in 2014-08-01 05:20:15.000000000 -0600
-@@ -62,15 +62,6 @@ AC_CHECK_HEADERS([libxml/parser.h libxml
- [AC_MSG_ERROR([libxml2 headers MIA])])
- AC_HAVE_LIBRARY(xml2,,[AC_MSG_ERROR([libxml2 not found])])
+diff -purN btscanner-2.1.orig/btscanner.xml btscanner-2.1/btscanner.xml
+--- btscanner-2.1.orig/btscanner.xml 2004-11-01 04:56:41.000000000 -0700
++++ btscanner-2.1/btscanner.xml 2013-04-10 23:54:38.000000000 -0600
+@@ -1,9 +1,9 @@
+ <?xml version="1.0" encoding="UTF-8"?>
+-<!DOCTYPE btscanner SYSTEM "file:///usr/local/etc/btscanner.dtd">
++<!DOCTYPE btscanner SYSTEM "file:///etc/btscanner/btscanner.dtd">
+ <btscanner>
+ <files>
+ <log>btscanner.log</log>
+- <oui>/usr/local/share/oui.txt</oui>
++ <oui>/usr/share/btscanner/oui.txt</oui>
+ <store>~/bts</store>
+ </files>
+
+diff -purN btscanner-2.1.orig/configure btscanner-2.1/configure
+--- btscanner-2.1.orig/configure 2005-11-21 06:57:26.000000000 -0700
++++ btscanner-2.1/configure 2013-04-10 23:55:37.000000000 -0600
+@@ -5308,14 +5308,14 @@ fi
+ ac_cv_lib_xml2=ac_cv_lib_xml2_main
+
-# CFLAGS
-CFLAGS="$CFLAGS -Wall -pthread -Wshadow -Wbad-function-cast \
@@ -13,45 +28,14 @@ diff -up btscanner-2.1/configure.in.orig btscanner-2.1/configure.in
- -Wcast-qual -falign-functions -falign-labels -falign-loops\
- -pedantic -fstrict-aliasing -D_GNU_SOURCE -std=c99"
-# -fstack-check -fbounds-check"
--
- # cfg
- AC_MSG_CHECKING(the location of the config file)
- AC_ARG_WITH(cfgfile,
-@@ -86,7 +77,7 @@ AC_ARG_WITH(cfgdtd,
- [ cfgdtd="file://$sysconfdir/btscanner.dtd" ])
- AC_MSG_RESULT($cfgdtd)
-
--CFLAGS="$CFLAGS -DCFG_FILE=\\\"$cfgfile\\\" -DCFG_DTD=\\\"$cfgdtd\\\""
-+CPPFLAGS="$CPPFLAGS -DCFG_FILE=\\\"$cfgfile\\\" -DCFG_DTD=\\\"$cfgdtd\\\""
-
- # output
- AC_CONFIG_FILES([Makefile])
-diff -up btscanner-2.1/Makefile.am.orig btscanner-2.1/Makefile.am
---- btscanner-2.1/Makefile.am.orig 2004-11-01 04:55:33.000000000 -0700
-+++ btscanner-2.1/Makefile.am 2014-08-01 05:21:11.000000000 -0600
-@@ -23,7 +23,8 @@
++## CFLAGS
++#CFLAGS="$CFLAGS -Wall -pthread -Wshadow -Wbad-function-cast \
++# -Wformat -Wparentheses -Wsign-compare \
++# -Wstrict-prototypes -Wtrigraphs -Wundef -Wuninitialized \
++# -W -Wunused -Wformat-security -Wmissing-braces -Wbad-function-cast \
++# -Wcast-qual -falign-functions -falign-labels -falign-loops\
++# -pedantic -fstrict-aliasing -D_GNU_SOURCE -std=c99"
++## -fstack-check -fbounds-check"
- bin_PROGRAMS = btscanner
-
--INCLUDES = -I$(top_srcdir)
-+AM_CFLAGS = -Wall -pthread
-+AM_CPPFLAGS = -D_GNU_SOURCE
-
- btscanner_SOURCES = main.c main.h \
- threader.c threader.h \
-diff -up btscanner-2.1/screen.c.orig btscanner-2.1/screen.c
---- btscanner-2.1/screen.c.orig 2005-08-17 15:15:59.000000000 -0600
-+++ btscanner-2.1/screen.c 2014-08-01 05:20:15.000000000 -0600
-@@ -985,9 +985,9 @@ int screen_init_bf(void)
- bdaddr_t start, end;
-
- screen_init_bf_retry:
-- memset(&cb, 0, sizeof(cbuf_t));
-- memset(&start, 0, sizeof(cbuf_t));
-- memset(&end, 0, sizeof(cbuf_t));
-+ memset(&cb, 0, sizeof(cb));
-+ memset(&start, 0, sizeof(start));
-+ memset(&end, 0, sizeof(end));
- ret = 0;
- for (dl = 1; dl && bts_run; ) {
- switch(screen_textbox("Start address", BD_RE, &cb)) {
+ # cfg
+ echo "$as_me:$LINENO: checking the location of the config file" >&5