summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaha2016-02-06 21:06:37 -0500
committerTaha2016-02-06 21:06:37 -0500
commit221a87371dc6dde265d619c93637a83c2f48f979 (patch)
treeecd8fd857f959be4e5d54fad491bf365472ce3ce
downloadaur-221a87371dc6dde265d619c93637a83c2f48f979.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD24
-rw-r--r--btsync-autoconfig.install20
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..366f1a8fccc8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Feb 7 02:05:46 UTC 2016
+pkgbase = btsync-autoconfig
+ pkgdesc = Create default config files when users launch btsync, if necessary
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/emlun/btsync-autoconfig
+ install = btsync-autoconfig.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = btsync
+ source = btsync-autoconfig.install
+ source = git+https://github.com/emlun/btsync-autoconfig.git#tag=2.0.0
+ md5sums = b9ce24af305d037b97a2e106cd9aa936
+ md5sums = SKIP
+ sha256sums = 244652e90656babb5383168c4ec65491ce676fe9a6dfa6a26fbfad9d33b03bdf
+ sha256sums = SKIP
+
+pkgname = btsync-autoconfig
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48fc07549973
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Emil Lundberg <lundberg.emil@gmail.com> (AUR: Lorde; GitHub: emlun)
+# Contributor: Justin Patera serialhex@gmail.com
+
+pkgname=btsync-autoconfig
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Create default config files when users launch btsync, if necessary"
+arch=('any')
+url='https://github.com/emlun/btsync-autoconfig'
+license=('GPL')
+depends=('btsync')
+makedepends=('git')
+install="${pkgname}.install"
+source=("${install}"
+ "git+${url}.git#tag=${pkgver}")
+md5sums=('b9ce24af305d037b97a2e106cd9aa936'
+ 'SKIP')
+sha256sums=('244652e90656babb5383168c4ec65491ce676fe9a6dfa6a26fbfad9d33b03bdf'
+ 'SKIP')
+
+package() {
+ cd "${pkgname}"
+ make install DESTDIR="${pkgdir}" PKGNAME="${pkgname}"
+}
diff --git a/btsync-autoconfig.install b/btsync-autoconfig.install
new file mode 100644
index 000000000000..93cf2cfcc7ed
--- /dev/null
+++ b/btsync-autoconfig.install
@@ -0,0 +1,20 @@
+post_install() {
+ systemctl --global enable btsync-autoconfig.service
+cat << EOF
+
+ Whenever a user starts the btsync user service, the btsync-autoconfig service
+ will create ${HOME}/.config/btsync/btsync.conf with default contents, if it
+ does not already exist. The service will also create the configured
+ storage_path directory if it does not already exist.
+
+ You may want to change the device_name, webui.login and webui.password
+ settings from the default. You can either edit the config file directly or use
+ the /usr/share/btsync-autoconfig/btsync-makeconfig.sh script, pass it the
+ --help flag to learn more about it.
+
+EOF
+}
+
+pre_remove() {
+ systemctl --global disable btsync-autoconfig.service
+}