summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsvexican2017-01-27 19:53:47 -0600
committersvexican2017-01-27 19:53:47 -0600
commit02a22fb4270fb1e367017a4977cb84abc514ad87 (patch)
treef3985f55f3f8a32d05893b0ca1493920f94ba25f
downloadaur-02a22fb4270fb1e367017a4977cb84abc514ad87.tar.gz
Going public
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ac6d84c6bae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bubbleswm-git
+ pkgdesc = bubbles is opinionated, tiny, bloat-less (=> fast) floating window manager for X.
+ pkgver = 8984443
+ pkgrel = 1
+ url = https://github.com/svexican/bubbleswm
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libconfig
+ depends = libx11
+ depends = libxinerama
+ provides = bubbleswm
+ source = git+https://github.com/svexican/bubbleswm.git
+ md5sums = SKIP
+
+pkgname = bubbleswm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e8ceff26fa2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: svexican (svexican@gmail.com)
+
+pkgname=bubbleswm-git
+pkgver=8984443
+pkgrel=1
+pkgdesc="bubbles is opinionated, tiny, bloat-less (=> fast) floating window manager for X."
+arch=('i686' 'x86_64')
+url="https://github.com/svexican/bubbleswm"
+license=('GPL')
+depends=('libconfig' 'libx11' 'libxinerama')
+provides=("${pkgname%-*}")
+source=('git+https://github.com/svexican/bubbleswm.git')
+md5sums=('SKIP')
+
+pkgver() {
+ # Get the tag of the latest commit
+ cd ${pkgname%-*}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgname%-*}
+ msg "Starting make..."
+ make
+
+ git submodule init
+ git submodule update
+
+ cd xowl
+ make
+}
+
+package() {
+ cd ${pkgname%-*}
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+
+ cd xowl
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+}