summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaveB2015-09-21 14:32:16 +0200
committerDaveB2015-09-21 14:32:16 +0200
commit886ff06bd5e1443b36a38e90b2cd11b064eb4f0b (patch)
tree6a2ac4c2bda2accf9b140b79a1c3c5d80c59fd7b
downloadaur-886ff06bd5e1443b36a38e90b2cd11b064eb4f0b.tar.gz
Initial import – Version 9.4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
-rw-r--r--bubbleupnpserver.install43
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2dc18ad84020
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bubbleupnpserver
+ pkgdesc = Stream content to Android devices over the Internet – requires UPNP/DNLA backend e.g. Mediatomb
+ pkgver = 0.9.4
+ pkgrel = 1
+ url = http://www.bubblesoftapps.com/bubbleupnpserver/
+ install = bubbleupnpserver.install
+ arch = any
+ license = custom:bubbleupnpserver
+ depends = jre7-openjdk-headless
+ depends = ffmpeg
+ source = http://www.bubblesoftapps.com/bubbleupnpserver/BubbleUPnPServer-distrib.zip
+ md5sums = SKIP
+
+pkgname = bubbleupnpserver
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80d22cd5ff93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Dave Blair <mail@dave-blair.de>
+# Contributor: Nick Bair <njbair at gmail dot com>
+pkgname=bubbleupnpserver
+pkgver=0.9.4
+pkgrel=1
+pkgdesc="Stream content to Android devices over the Internet – requires UPNP/DNLA backend e.g. Mediatomb"
+arch=('any')
+url="http://www.bubblesoftapps.com/bubbleupnpserver/"
+license=('custom:bubbleupnpserver')
+depends=('jre7-openjdk-headless' 'ffmpeg')
+install=${pkgname}.install
+source=("http://www.bubblesoftapps.com/bubbleupnpserver/BubbleUPnPServer-distrib.zip")
+md5sums=('SKIP')
+
+build() {
+ cd ${srcdir}
+
+ unzip -qfo "${srcdir}/BubbleUPnPServer-distrib.zip" -d ${srcdir}
+
+ msg2 "Creating a shell-accessible script"
+ echo "#! /bin/bash
+sudo /usr/share/${pkgname}/launch.sh
+" > ${srcdir}/${pkgname}.sh
+
+ msg2 "Installing systemd service unit file..."
+ echo "[Unit]
+Description=BubbleUPnP Server
+[Service]
+ExecStart=/usr/share/${pkgname}/launch.sh
+SuccessExitStatus=1 2 SIGKILL
+[Install]
+WantedBy=network.target" > ${srcdir}/${pkgname}.service
+}
+
+package() {
+ install -D -m644 ${srcdir}/LICENCE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -D -m644 ${srcdir}/bcprov-jdk16-146.jar ${pkgdir}/usr/share/${pkgname}/bcprov-jdk16-146.jar
+ install -D -m644 ${srcdir}/BubbleUPnPServerLauncher.jar ${pkgdir}/usr/share/${pkgname}/BubbleUPnPServerLauncher.jar
+ install -D -m755 ${srcdir}/launch.sh ${pkgdir}/usr/share/${pkgname}/launch.sh
+ install -D -m644 ${srcdir}/${pkgname}.service ${pkgdir}/usr/lib/systemd/system/${pkgname}.service
+ install -D -m755 ${srcdir}/${pkgname}.sh ${pkgdir}/usr/bin/${pkgname}.sh
+}
diff --git a/bubbleupnpserver.install b/bubbleupnpserver.install
new file mode 100644
index 000000000000..53afedc7a026
--- /dev/null
+++ b/bubbleupnpserver.install
@@ -0,0 +1,43 @@
+post_install() {
+ echo "
+========================================================================
+
+Before starting BubbleUPnP Server, have a look at the default config
+file located at /etc/default/bubbleupnpserver and make sure the defaults
+are OK.
+
+To start BubbleUPnP, you must first enable the service unit file:
+ # systemctl enable bubbleupnpserver
+
+Then start the service:
+ # systemctl start bubbleupnpserver
+
+To complete the configuration once the service has been started, point
+your web browser to:
+ http://localhost:58050
+ - or -
+ https://localhost:58051
+
+Full documentation is available at:
+ http://www.bubblesoftapps.com/bubbleupnpserver/
+
+========================================================================
+"
+}
+
+post_upgrade() {
+ echo "
+========================================================================
+
+If BubbleUPnP is already running, you need to restart it to finish the
+upgrade.
+
+To restart BubbleUPnP:
+ # systemctl restart bubbleupnpserver
+
+Full documentation is available at:
+ http://www.bubblesoftapps.com/bubbleupnpserver/
+
+========================================================================
+"
+}