summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Goguen2016-04-22 16:09:56 -0700
committerJoel Goguen2016-04-22 16:09:56 -0700
commit96b8a5253678f933bca674ab073dc61b1bdf148c (patch)
treec23c65d8aecbeef70a8faf9ee5f6babc1fe2b992
downloadaur-96b8a5253678f933bca674ab073dc61b1bdf148c.tar.gz
v2016.04.18.01
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
-rw-r--r--python-test-output.patch15
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e49aabd8c8fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Apr 22 22:32:00 UTC 2016
+pkgbase = buck
+ pkgdesc = A fast build system that encourages the creation of small, reusable modules over a variety of platforms and languages.
+ pkgver = 2016.04.18.01
+ pkgrel = 1
+ url = https://buckbuild.com
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = java-environment>=7
+ makedepends = apache-ant
+ depends = java-runtime-headless>=7
+ depends = python2
+ source = https://github.com/facebook/buck/archive/v2016.04.18.01.tar.gz
+ source = python-test-output.patch
+ sha256sums = 53650306787f5eebf53595f1cc65a2a025694194d3813ede9474e1c1bd7acafc
+ sha256sums = 45f128aeb4912aa417a774fac6d27805b92193231b418dc0a1f12afc923d5402
+
+pkgname = buck
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b18a496b2279
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Joel Goguen <contact+aur@jgoguen.ca>
+
+pkgname=buck
+pkgver="2016.04.18.01"
+pkgrel=1
+pkgdesc="A fast build system that encourages the creation of small, reusable modules over a variety of platforms and languages."
+arch=('i686' 'x86_64')
+depends=('java-runtime-headless>=7' 'python2')
+makedepends=('java-environment>=7' 'apache-ant')
+optdepends=('watchman: prevent Buck from parsing all of your build files every time')
+url="https://buckbuild.com"
+license=('Apache')
+source=(
+ "https://github.com/facebook/${pkgname}/archive/v${pkgver}.tar.gz"
+ 'python-test-output.patch'
+)
+sha256sums=(
+ '53650306787f5eebf53595f1cc65a2a025694194d3813ede9474e1c1bd7acafc'
+ '45f128aeb4912aa417a774fac6d27805b92193231b418dc0a1f12afc923d5402'
+)
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -p1 <"${srcdir}/../python-test-output.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ant
+ ./bin/buck build buck
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ BINPATH=$(./bin/buck targets --show_output buck | cut -d' ' -f2)
+ install -Dm 755 "${BINPATH}" "${pkgdir}/usr/bin/buck"
+}
diff --git a/python-test-output.patch b/python-test-output.patch
new file mode 100644
index 000000000000..4b1224c00c6b
--- /dev/null
+++ b/python-test-output.patch
@@ -0,0 +1,15 @@
+--- ./test/com/facebook/buck/cli/ExternalTestRunnerIntegrationTest.java.orig 2016-04-22 15:23:01.347436678 -0700
++++ ./test/com/facebook/buck/cli/ExternalTestRunnerIntegrationTest.java 2016-04-22 15:23:24.214103542 -0700
+@@ -72,9 +72,9 @@
+ result.assertSuccess();
+ assertThat(
+ result.getStdout(),
+- is(equalTo("[[0.0, [u'dir/simple.py']], " +
+- "[0.75, [u'dir/also_simple.py', u'dir/simple.py']], " +
+- "[1.0, [u'dir/also_simple.py']]]\n")));
++ is(equalTo("[[0.0, ['dir/simple.py']], " +
++ "[0.75, ['dir/also_simple.py', 'dir/simple.py']], " +
++ "[1.0, ['dir/also_simple.py']]]\n")));
+ }
+
+ @Test